Blurry Pixelart?

Get help using Construct 2

Post » Sat Feb 18, 2012 11:54 am

So, I quite recently bought this great tool for simple game developing and I love it, I just encountered a problem with pixelart where as when I try to run the game it seems to blur them up in an attempt of smoothing the pixels out, which I don't want to happen to my pixel-art-sprites, in other words, I'd like to have them crisp and pixely, I googled around for a little and couldn't find any solution to the problem, I even went as far as taking a fast glance at the manual, yet I was left clueless to how to solve my problem...

Here's a CAPX of a VERY simply test containing a VERY simple pixel-sprite which is for some reason smoothed out when it's played: Click me

All help is appreciated and I thank you all in advance for the time I took from your day haha :)helehole2012-02-18 12:07:56
B
6
G
2
Posts: 39
Reputation: 1,280

Post » Sat Feb 18, 2012 12:11 pm

I also have been having this problem. I have been resizing my pixel art with photoshop then placing them into my game, and that seems to fix them but if you re-size them in C2 they end up all blurred. Maybe this is some kind of bug.
B
50
S
11
G
8
Posts: 479
Reputation: 9,911

Post » Sat Feb 18, 2012 12:16 pm

oh haha thanks for the tip :) The pixel-resizing seems to have been a 'problem' since the first version of the... first version lol :)
B
6
G
2
Posts: 39
Reputation: 1,280

Post » Sat Feb 18, 2012 12:31 pm

I'd imagine most modern software assumes you want filtering when you rescale something...It doesn't sound like a bug, it just sounds like its doing something other than what you want...

I'm new to C2 myself, so maybe someone else can be more help, but I think you want to make your game based on a low res window size like 320x240 and then have the game enlarge at run time WITHOUT filtered scaling... I'll report back if I get the time to figure out how to do this.
B
45
S
8
G
4
Posts: 414
Reputation: 6,805

Post » Sat Feb 18, 2012 12:51 pm

If you are using webgl enabled, the filtering is automatic.
Check in layout preferences, and you'll see options to turn webgl off, and set filtering to point, if you want to keep it.
Image Image
B
161
S
48
G
89
Posts: 7,347
Reputation: 66,249

Post » Sat Feb 18, 2012 12:59 pm

[QUOTE=newt] If you are using webgl enabled, the filtering is automatic.
Check in layout preferences, and you'll see options to turn webgl off, and set filtering to point, if you want to keep it.[/QUOTE]

I think this broke in one of the latest builds. I used to keep WebGL off & pixel rounding on and the graphics would be perfectly fine, even when zooming in Chrome. Now they're blurry regardless of what settings I use.Tokinsom2012-02-18 13:00:24
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024

Post » Sat Feb 18, 2012 1:09 pm

IT WORKS! Oh thank you so much! awesome :) (to newt)helehole2012-02-18 13:09:47
B
6
G
2
Posts: 39
Reputation: 1,280

Post » Sat Feb 18, 2012 1:21 pm

What version of C2 are you using helehole? Because I just tried what newt said with your .capx and it's still all blurred.
B
50
S
11
G
8
Posts: 479
Reputation: 9,911

Post » Sat Feb 18, 2012 1:24 pm

Release 79.4 (32 bit) Running on a Windows 7 Home Premium machine ;)
B
6
G
2
Posts: 39
Reputation: 1,280

Post » Sat Feb 18, 2012 1:28 pm

Hmm, I just cant get it to work with turning webgl off, and setting filtering to point. Maybe I just have a crappy pc.
B
50
S
11
G
8
Posts: 479
Reputation: 9,911

Next

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 19 guests