"Bounce off Solids" is not active in new spawns

Get help using Construct 2

Post » Wed Aug 16, 2017 6:43 pm

Hi everyone, i'm developing this game where some enemies are on screen on the start of the layout. I've set them with "bounce off solids" true. They work fine, they bounce.

However, more enemies spawn over time, but these spawns behave as if the "bounce off solids" setting is set to false.

How can i fix this? i tried looking for a "on created, bounce off solids true" , but didn't find anything like it, i tried with " on created, bounce off [the object they're meant to bounce off of]" but it doesn't work.

How can i make it so that every instance that is created, is set to bounce off solids TRUE and not only the ones that are already in the layout that i manually set ?
B
5
Posts: 25
Reputation: 271

Post » Thu Aug 17, 2017 4:10 am

Hey Chris,

When you spawn a new object it generally takes all its variables from another object in the project. Is there an object of the same type somewhere in your layout with different settings perhaps?
ImageImage
B
123
S
23
G
7
Posts: 1,071
Reputation: 13,091

Post » Fri Aug 18, 2017 5:58 pm

GenkiGenga wrote:Hey Chris,

When you spawn a new object it generally takes all its variables from another object in the project. Is there an object of the same type somewhere in your layout with different settings perhaps?



Thanks Genga! that might have been it. i solved it in a more complex way anyways.

I didn't have instances of it in the LAYOUT, but maybe in other layouts of the project. Maybe that was it...

Thanks
B
5
Posts: 25
Reputation: 271


Return to How do I....?

Who is online

Users browsing this forum: Armench, farsen and 13 guests