Broken Help link in r101

Bugs will be moved here once resolved.

Post » Sat Sep 01, 2012 3:28 am

this error message pops up when I click the help link at the bottom of the Layer properties list. Tried it in a couple projects, so I don't think it's related to what behaviors or effects were included.
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Unknown layer property modified!

Condition: false
File: Bars\PropertiesBar - Layer.cpp
Line: 278
Function: void __cdecl LayerPropertyChangedHandler::OnPropertyChanged(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 101 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------
B
201
S
52
G
30
Posts: 897
Reputation: 36,621

Post » Mon Sep 03, 2012 5:10 pm

Oops, you're right. Should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,630


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests