Browser back not working

Bugs will be moved here once resolved.

Post » Tue Jun 04, 2013 6:13 am

Link to .capx file (required!):
https://www.dropbox.com/s/7xnwut2nw0om4cq/no_back.capx

Steps to reproduce:
1. Preview game.
2. Navigate to google.com (or any other site).
3. Navigate to game (localhost:50000)
4. Click on image

Observed result:
Error message indicating Object [object global] has no method 'back'

Expected result:
Should return to google.com (or whatever the previous site was)

Browsers affected:
Chrome: yes
Firefox: no
Internet Explorer: yes

Operating system & service pack:
Win 7 64 bit

Construct 2 version:
127 & 131 (tested in both)Schism2013-06-04 20:51:20
B
3
Posts: 3
Reputation: 306

Post » Tue Jun 04, 2013 12:47 pm

The correct action to use in this case is 'forward', since you've already gone back. But there shouldn't be a JS error, that should be fixed in the next build. It also looks like at least Chrome has deprecated and removed the automatic forward/back navigation features, so maybe we should just remove them...
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Tue Jun 04, 2013 8:56 pm

Thank you for responding.

The correct action is not forward. When I said "navigate back to the game", I didn't mean hit the back button. I've updated the original post to be clearer.

I think those navigation features should definitely be removed if they don't work. They are misleading. What I ended up doing was having the browser navigate to a URL and directing it to Browser.Referrer. That's essentially the same thing.
B
3
Posts: 3
Reputation: 306


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests