Bubble Shooter : My chain work for 2 colours but not 3

Get help using Construct 2

Post » Wed Aug 03, 2016 3:13 pm

HI,

I'm currently working on a Bubble Shooter-like and I manage to create a chain system to detect which gem of a colour is connected to another. It's not the best system but it's work, or more precisely : it's almost work. The player can shoot gems of 3 colours: Purple, Green and Yellow. My chain chain system works for the purple gems and the green gems but not for the yellow. They are detected but they're not deleted.

There is my capx.

Thanks in advance for the help.

My code works like this :

When a gem is snap with ohers i create six objects where the gem can connect with others. If those objects touch a gem, the gem will be mark and spawn others objects until there is no more gem to connect with. After that all the gem connected are detroyed.
This work for the Purple and the green but not for the yellow ones. The yellow ones are marked as picked but the function stop and don't mark them for being delete.
See my capture below for a more clear explanation.
Last edited by vivalabello on Thu Aug 04, 2016 8:42 am, edited 3 times in total.
B
7
S
1
Posts: 30
Reputation: 787

Post » Thu Aug 04, 2016 7:59 am

There are some pictures of my chain system :

Image
Image
B
7
S
1
Posts: 30
Reputation: 787

Post » Thu Aug 04, 2016 9:17 am

I managed to fix my problem : The problem cames from a bud use of an "Else".

Image
B
7
S
1
Posts: 30
Reputation: 787


Return to How do I....?

Who is online

Users browsing this forum: David181, jorgmaquoi, unicornspitfire and 18 guests