Bug: Collision poly has less than 3 points

Bugs will be moved here once resolved.

Post » Fri Jul 27, 2012 9:18 pm

Sorry for the double post but I/ve realised my original post was in "closed bugs" and I thought that it belonged here.

The error started yesterday when I tried to import a sprite directly to my layout by drag&droping from windows. A bug error poped up saying the sprite has problems with its collision poly.

Conflicting png



I tried to import this png from the animation editor and it looked to work but today, when I tried to open the caproj, this error appeared.



Any ideas? Pless tell me I didn't loose my proyect.

Im working with the b99 on windows 7. Don't have a capx but I may attach the caproj if needed.

bye and thanks!





B
9
S
3
G
3
Posts: 39
Reputation: 3,112

Post » Fri Jul 27, 2012 9:23 pm

I attach a capx with the error reproduced.

http://www.antylope.com.ar/less3pointpoly.rar
B
9
S
3
G
3
Posts: 39
Reputation: 3,112

Post » Sat Jul 28, 2012 4:59 pm

Open your .caproj file with a text editor, go to line 1502 and add a third collision point by yourself.

Not working:
<collision-poly>
                            <point x="0.985401" y="0.5" />
                            <point x="0.0145985" y="0.5" />
</collision-poly>

Change to:
<collision-poly>
                            <point x="0.985401" y="0.5" />
                            <point x="0.0145985" y="0.5" />
                            <point x="0.01" y="0.5" />
</collision-poly>
B
11
S
3
Posts: 224
Reputation: 2,028

Post » Sat Jul 28, 2012 7:53 pm

Thanks man! It looks so easy now. I should read the error first before freaking out. My mistake.
B
9
S
3
G
3
Posts: 39
Reputation: 3,112

Post » Mon Jul 30, 2012 4:04 pm

Thanks for the report, it turns out C2 guesses the collision poly incorrectly for this image. Should be fixed in the next build!
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests