Bug - game ignores user input

Discussion and feedback on Construct 2

Post » Wed Feb 09, 2011 11:52 pm

Hi!

I've stumbled upon this tool while I was researching HTML5 game creation and it looked cool so I thought I'd give it a try.

I made a [u:32cvh7nc](very)[/u:32cvh7nc] simple project so I could see how your system performs.
The simple application is like that, there's a single sprite that responds to:
S - Rotate 45 degrees clockwise
Tab - Rotate 45 degrees counter-clockwise (As I expected it wouldn't work nicely, so don't bother with this, it will switch control to the browser and do crazy things)
Enter - Reset rotation

Now, that TAB bug is reasonable, but what bothered me was this. I tried adding some very basic CSS and other content (Text and image) to see if it would interfere with the game (Nothing serious, take a look at the source) , and then I found quite a weird bug. Seems like that after you click anywhere on the screen, the game no longer responds to user input!
No matter how much i tweaked the CSS nothing solved it, so I randomly pressed the keys and found something even weirder! After you lose control, if you press a certain key combination, and then click on the canvas, the control is restored!

After losing control, do: Enter, S S S, Tab Tab, Enter and then click on the canvas. Control should be restored! (It works for me most of the times, at least...)

The game: http://eztax.zxq.net/bug.html
The capx source: http://eztax.zxq.net/bug.zip

I hope this bug report can help you! I'm looking forward for more stable versions of Construct 2! :D
B
1
G
1
Posts: 6
Reputation: 437

Post » Wed Feb 09, 2011 11:56 pm

that actually makes sense. There is a canvas object that everything is being drawn on and in order to take input it has to have focus. when you click off of it it loses focus and wont respond to it. When you click on the canvas it regains focus. at least that is the way it should work.
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Wed Feb 09, 2011 11:57 pm

The problem is that without the key combination clicking the canvas won't restore any control!
B
1
G
1
Posts: 6
Reputation: 437

Post » Thu Feb 10, 2011 12:39 am

have you tried just double clicking?
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Thu Feb 10, 2011 12:58 am

Yes, nothing but that combination works, as weird as it may sound. Try it yourself, there's a link to the bugged HTML file.
B
1
G
1
Posts: 6
Reputation: 437

Post » Thu Feb 10, 2011 1:36 am

No I did try it. It works fine for me. if I click off and then double click it again it works fine.
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Thu Feb 10, 2011 11:31 am

Really? are you trying my html file or you're rebuilding it yourself? it could be because the css or content I added
which browser you use? I get the bug in both firefox and chrome.
B
1
G
1
Posts: 6
Reputation: 437

Post » Thu Feb 10, 2011 3:17 pm

Did anyone reproduce the bug yet?
B
1
G
1
Posts: 6
Reputation: 437

Post » Thu Feb 10, 2011 5:52 pm

I tried your file in chrome. even if it is a bug you should always post bugs to the tracker if you want them fixed not on the forums
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Thu Feb 10, 2011 6:14 pm

Right! Posted in the tracker, thank you! :D
B
1
G
1
Posts: 6
Reputation: 437

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests