Bug with colors...maybe?

Discussion and feedback on Construct 2

Post » Sun Jan 22, 2017 1:33 pm

@Eisenhans: Sorry it was late, I meant "this type of comment" (as in this "personal attack" without more informations in regards to the topic itself) not "your type of comments" (as in "your general comments").

@Kazan: Also Eisenhans screenshot does bring an interesting point like yours, it is not a matter of monitor (since people who executed the capx and had similar color on their monitor do see the different colors in your screenshot as well, meaning when you are executing the WebGL shader, the result is different RGB colors, whereas it is not on other peoples' computer).
It could be a matter of graphic card/chipset.

Strange indeed that running the provided capx as is results appear so different from a computer to another.

For people trying, please can you put your computer specs (OS/Graphic card/NW.JS version I guess should be enough) to see if some trend jumps out ?

Mine : Win 7 pro, Nvidia GTX 560 Ti, NW.JS 18.7 then updated to latest NW.JS 19.4 and still the same result of the same color for both objects.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
296
S
119
G
96
Posts: 7,332
Reputation: 71,306

Post » Sun Jan 22, 2017 1:39 pm

@Kyatric I'm just messing with you ;) No hard feelings. My original comment was inappropriate in the first place.

My working theory right now is: driver issue. My C2 system is Win8.1 pro, NVidia GTX 760 *but* (for entirely different reasons) with a super antique Nvidia driver (358.91). It may very well have been an issue that has been fixed since. So in OP's place I would check that first.
B
79
S
29
G
32
Posts: 482
Reputation: 19,915

Post » Mon Jan 23, 2017 5:45 am

It appears to be a feature of chrome/nwjs that uses a color profile to adjust the colors. Here is a previous discussion on it or something very similar:
viewtopic.php?f=152&t=183785&p=1078592&hilit=Profile+Color#p1078592

As I recall if you look at the Windows display settings there is a color profile settings tab for the monitor that lists color profiles installed. It really just depends on if one was installed with your driver or not. You can remove them too.
B
94
S
33
G
118
Posts: 5,395
Reputation: 75,851

Post » Mon Jan 23, 2017 10:46 am

R0J0hound wrote: It really just depends on if one was installed with your driver or not. You can remove them too.


There is none on this system. Don't know about the OP's situation though. Here it was specifically set up to not have it.
B
79
S
29
G
32
Posts: 482
Reputation: 19,915

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests