Buggy 9patch in Firefox

Bugs will be moved here once resolved.

Post » Thu Sep 11, 2014 9:57 pm

9patch bug
This bug seems only effect Firefox. If you use some object over the 9patch object, 9patch object's center part seem invisible in some conditions. If you change the size of window (not in construct, in browser) it looks normal again. Another weird thing is, if you preview with run layout button 9patch center part is problematic, but if you use debug it looks normal again.

Edit: I upload a picture.

Attach a Capx
capx is attached

Description of Capx
On the start of layout 9patch is problematic, if you click the next button drawing is refreshed and looks normal

Steps to Reproduce Bug
  • Just run the layout

Observed Result
Center of the 9patch is invisible

Expected Result
Center of the 9patch has to be visible

Affected Browsers
  • Chrome 37: (NO)
  • FireFox 32: (YES)
  • Internet Explorer 11: (NO)

Operating System and Service Pack
Windows 8.1

Construct 2 Version ID
Construct 2 Personal r179 64bit Steam
You do not have the required permissions to view the files attached to this post.
Last edited by mrcgkh on Fri Sep 12, 2014 11:36 am, edited 1 time in total.
B
21
S
8
G
6
Posts: 177
Reputation: 8,134

Post » Fri Sep 12, 2014 6:36 am

I'm using latest Firefox and it looks OK to me.

Maybe a couple of screen grabs will help to show what your experiencing?
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Fri Sep 12, 2014 2:18 pm

Renders just fine here in Firefox too.

Check your graphics drivers are up to date - it could be a driver bug.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Fri Sep 12, 2014 9:19 pm

I used geforce 340.52 drivers (latest one) also windows is up to date. r179 is buggy but after updating to r180 it works normally.
B
21
S
8
G
6
Posts: 177
Reputation: 8,134


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests