Page 5 of 5

Re: Bugs to fix FAST

PostPosted: Wed Nov 14, 2007 10:13 am
by deadeye
One of the object icons in the Layers panel has an incorrect icon. It's a 3d Box object. I'm sure you're not totally sick of hearing about that object yet :wink:

Anyway, sometimes the icon displayed is my player sprite, sometimes it's the Mouse&Keyboard icon. It switches around to different icons, which is strange enough. When I open the picture editor to edit the icon, I get a couple of different errors. Sometimes I get:

[code:2q1myh74]An invalid texture handle was used.

Good luck![/code:2q1myh74]

And other times I get:

[code:2q1myh74]Runtime Error!

Program: C:\blahblah\Construct.exe

R6205
- pure virtual function call[/code:2q1myh74]

I'm also getting incorrect icons for other objects in the event conditions and actions selectors, and in the event sheet editor, which makes it a little confusing.

Re: Bugs to fix FAST

PostPosted: Wed Nov 14, 2007 11:31 am
by Ashley
Can you send me a .cap with the wrong icons? [email protected], cheers!

Re: Bugs to fix FAST

PostPosted: Wed Nov 14, 2007 7:02 pm
by deadeye
[quote="Ashley":3j32doto]Can you send me a .cap with the wrong icons? [email protected], cheers![/quote:3j32doto]

[code:3j32doto]A .cap file was sent.

Good luck![/code:3j32doto]

Re: Bugs to fix FAST

PostPosted: Thu Nov 15, 2007 2:08 am
by Ashley
I've had a look, and I can see why it crashes - one of the object's icons didn't save for some reason, so it fails to load it and fails editing it. I've no idea why it never saved properly - can you remember what you did before it happened?

Re: Bugs to fix FAST

PostPosted: Thu Nov 15, 2007 5:03 am
by deadeye
Unfortunately, no. Sorry :(

I first noticed the icon was incorrect a few days ago, before v0.84 came out. I figured it was just a tiny little bug, and I could just edit the icon any time. When I finally got around to editing it this morning, I discovered that the problem was bigger than I first thought.

It's not a terribly big .cap though, I can try recreating it from scratch and see if it happens again. I'll let you know what I find, if anything.