build errors latest construct 2 and intel xdk

Get help using Construct 2

Post » Wed Jun 29, 2016 4:43 am

BUILD FAILED

Total time: 14.121 secs
ERROR building one of the platforms: Error: .../test/platforms/android/gradlew: Command failed with exit code 1
You may not have the required environment or OS to build this project
Error: .../test/platforms/android/gradlew: Command failed with exit code 1
at ChildProcess.whenDone (.../test/platforms/android/cordova/node_modules/cordova-common/src/superspawn.js:139:23)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at maybeClose (internal/child_process.js:821:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

I have tried with and with out plugins. I am getting very feed up with all this crap.

I have spent days trying to find out what the issue is. I have tried compiling 5 apps so far and they are all giving the same error. did construct 2 change and now does not work with intel xdk? If so is there another way to compile apps that is just as straight forward?
any way to fix this? please use basic steps to take. as I know little to nothing about adding hardcode to file and what I am looking for.
B
29
S
13
G
10
Posts: 355
Reputation: 8,317

Post » Wed Jun 29, 2016 7:09 am

export your project in "www" subfolder of "your project" folder.


Now Open "your project" folder
now open "intelxdk.config.additions" xml file in your favorate editor or you can open in intel XDK too
Ctrl + A & del everything
and paste below codes

<preference name="debuggable" value="false" />
<intelxdk:crosswalk xwalk-command-line="--ignore-gpu-blacklist" />
<intelxdk:crosswalk xwalk-command-line="--disable-pull-to-refresh-effect" />
<preference name="CrosswalkAnimatable" value="false" />

save it

This Problem is covered in my this Tutorial
Image
B
64
S
39
G
45
Posts: 651
Reputation: 32,214

Post » Wed Jun 29, 2016 11:43 am

You should report these issues to Intel - Construct 2 does not control the build process, that's done by the Intel XDK.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Wed Jun 29, 2016 4:22 pm

Ashley wrote:You should report these issues to Intel - Construct 2 does not control the build process, that's done by the Intel XDK.


I did.
B
29
S
13
G
10
Posts: 355
Reputation: 8,317

Post » Wed Jun 29, 2016 4:23 pm

luckyrawatlucky wrote:export your project in "www" subfolder of "your project" folder.


Now Open "your project" folder
now open "intelxdk.config.additions" xml file in your favorate editor or you can open in intel XDK too
Ctrl + A & del everything
and paste below codes

<preference name="debuggable" value="false" />
<intelxdk:crosswalk xwalk-command-line="--ignore-gpu-blacklist" />
<intelxdk:crosswalk xwalk-command-line="--disable-pull-to-refresh-effect" />
<preference name="CrosswalkAnimatable" value="false" />

save it

This Problem is covered in my this Tutorial


I will give this a try right now.
B
29
S
13
G
10
Posts: 355
Reputation: 8,317

Post » Wed Jun 29, 2016 4:37 pm

Carbincopy wrote:
luckyrawatlucky wrote:export your project in "www" subfolder of "your project" folder.


Now Open "your project" folder
now open "intelxdk.config.additions" xml file in your favorate editor or you can open in intel XDK too
Ctrl + A & del everything
and paste below codes

<preference name="debuggable" value="false" />
<intelxdk:crosswalk xwalk-command-line="--ignore-gpu-blacklist" />
<intelxdk:crosswalk xwalk-command-line="--disable-pull-to-refresh-effect" />
<preference name="CrosswalkAnimatable" value="false" />

save it

This Problem is covered in my this Tutorial


I will give this a try right now.

I tried this and still get build error on all my apps. I did it to all just in case it might be helpful. but no go.
B
29
S
13
G
10
Posts: 355
Reputation: 8,317

Post » Wed Jun 29, 2016 5:17 pm

send ur capx file
i'll test it
Image
B
64
S
39
G
45
Posts: 651
Reputation: 32,214

Post » Wed Jun 29, 2016 5:37 pm

Carbincopy wrote:
Carbincopy wrote:
luckyrawatlucky wrote:export your project in "www" subfolder of "your project" folder.


Now Open "your project" folder
now open "intelxdk.config.additions" xml file in your favorate editor or you can open in intel XDK too
Ctrl + A & del everything
and paste below codes

<preference name="debuggable" value="false" />
<intelxdk:crosswalk xwalk-command-line="--ignore-gpu-blacklist" />
<intelxdk:crosswalk xwalk-command-line="--disable-pull-to-refresh-effect" />
<preference name="CrosswalkAnimatable" value="false" />

save it

This Problem is covered in my this Tutorial


I will give this a try right now.

I tried this and still get build error on all my apps. I did it to all just in case it might be helpful. but no go.

Ok! Here is an update. I don't have a clue as what the issue really was, But here is what I did differently and seams to have fixed the problem.

1. started with no plugins - exported cordova with xdk - minified (built successful)
2. added plugins one at a time and built each time successful
In intel xdk instead of using cordova directory which I had done in all prior attempts, I used all plugins form https://github.com
not sure if the cordova directory is out dated with older versions of the plugins, but none the less I now have my apps ready for google play store and will stay away from cordova directory in the future.
B
29
S
13
G
10
Posts: 355
Reputation: 8,317


Return to How do I....?

Who is online

Users browsing this forum: David181 and 17 guests