Bullet movement bug

Bugs will be moved here once resolved.

Post » Mon May 14, 2012 9:52 am

I am mucking around with my UI elements and stumbled across a weird bug. If the speed of my object (with bullet behav) is 0 and I change speed through an event - then object will only move to the left or right. If you set the speed on the object itself though (from the properties panel) it will move at any angle you like.

Maybe its by design i dont know, you just have to change the speed of the object itself from the properties menu to see what i mean.

http://dl.dropbox.com/u/13312935/bulletmovement.capx

The idea was that I was going to have UI elements sitting out of view and then slide them onto the interface by changing the speed from 0 to whatever. I can get around though by spawning the object (with its speed set) when I need it instead.

Ive added another example, this time its with the "every X seconds" action instead of "On start of layout". It works on the second time it clicks over (still goes to the right first though).GenkiGenga2012-05-14 11:54:25
ImageImage
B
73
S
16
G
6
Posts: 1,038
Reputation: 10,473

Post » Mon May 14, 2012 5:21 pm

It works if you set the speed before you set the angle of motion. I guess if a bullet isn't moving then it doesn't have an angle of motion, ie. it's 0.
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,000

Post » Mon May 14, 2012 9:44 pm

Ahh nice one @ramones, your right. I kind of expected it to work the other way around! This will save me some trouble in the future for sure.

Cheers.
ImageImage
B
73
S
16
G
6
Posts: 1,038
Reputation: 10,473


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests