Buttons unresponsive under Phonegap/WebOS/Android

Discussion and feedback on Construct 2

Post » Fri Feb 22, 2013 3:03 am

So I just went to HTML5Test.com to find out why exactly audio wouldn't work.

Turns out, WebOS 2.x does support neither AAC nor OGG (I was referring to the Enyo 1.0 SDK before, but apparently that info was only good for WebOS 3.x) but only WAV.

Now I'm not entirely sure what that means for me.

I've never used WAV as an audio resource for background music before, as I was under the impression that:

a) Being uncompressed, files are just way too big for several minutes/hours of music.

b) WAV lacks the concurrency of OGG/AAC.

a) is, in all likeliness, correct but please someone tell me I'm wrong about b) ;)

On another note: Since Construct2 forces me to convert WAV to OGG/AAC, I'll probably have to manually change all audio tags within the app's source. Correct?

EDIT: I just realized something. Apparently, the touch issue is due to the way Construct2 handles touch events. I haven't yet looked into the produced code, but this just became apparent after trying the touch emulation within Construct2. Blinx1232013-02-22 03:27:07
B
6
S
2
Posts: 206
Reputation: 1,685

Post » Sat Feb 23, 2013 5:38 pm

Quick update.

Buttons do work fine now. I switched to the standard OnClick action and disabled touch emulation. Touch actions are still a horrible mess. Depending on where I place them, they're either slower (sprites) or don't work at all (buttons).

Audio is still not working though. I slightly altered the function querying the browser for OGG compatibility. While this did work with IE9 and an MP3 file, I can't quite get it to work with .WAV and my HP Pre 3.
B
6
S
2
Posts: 206
Reputation: 1,685

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Artpunk, blurymind, humanescape, newt and 3 guests