C2 Crash when opening any layout

Bugs will be moved here once resolved.

Post » Thu Aug 28, 2014 5:13 am

Problem Description
Opening any Project or creating a new Project make C2 behave strangely. Opening a layout or zoming it makes C2 crash

Attach a Capx
Any capx crash it

Description of Capx
No need for Capx, opening any example will do. In fact just opening C2 without any project makes C2 looks weird, see attachment images.

Steps to Reproduce Bug
  • Open Construct2
  • Open any C2 file

Observed Result
C2 interface become unusable, particulary when opening a layout.

Expected Result
C2 should work fine.

Affected Browsers
  • Not a problem of browser.

Operating System and Service Pack
Windows 7 Ultimate - 64 bits.

Construct 2 Version ID
Construct2 178- 64bits (although older version crash)
You do not have the required permissions to view the files attached to this post.
B
10
S
2
G
1
Posts: 48
Reputation: 1,265

Post » Thu Aug 28, 2014 6:22 am

Ok I read your advice about bad graphic drivers, so I already send a request to Intel about this problem. Hope it is a driver problem. Nobody with a Intel Core i7 4600 HD got the same issue?
B
10
S
2
G
1
Posts: 48
Reputation: 1,265

Post » Thu Aug 28, 2014 2:25 pm

Closing as very likely a graphics driver problem - even if you have the latest driver it can still sometimes be broken. If you have a dual-GPU laptop (e.g. Intel HD graphics + nVidia card), try checking that the other GPU's driver is fully up to date as well (since you have to keep both drivers up to date on such systems).
Scirra Founder
B
399
S
236
G
89
Posts: 24,525
Reputation: 195,382

Post » Thu Aug 28, 2014 6:42 pm

Nope, just the Intel Graphic Card.

I got an idea , how about creating a webpage on scirra to keep the compatibility of C2 in different systems. For example, I got two other machines with Core i5, where its works like a charm. Maybe it just the driver on I7 - 4th generation, will update this post if Intel give me an answer.

Keep this amazing IDe working :)
B
10
S
2
G
1
Posts: 48
Reputation: 1,265

Post » Tue Sep 23, 2014 3:10 am

Hey Ashley, got some updates about this problem. I just found that Installing the 32bit version of Construct2 make it works. I formatted my PC and installed a vanilla windows on it. I test installing again C2 in 64bits and it crashed as expected, but with the 32bit version, it doesnt show any problem. My drivers are up to date, I even installed a beta version of the driver as suggested by Intel Customer Support to no avail.

So ,well, hope this help someone with the same problem!
B
10
S
2
G
1
Posts: 48
Reputation: 1,265

Post » Wed Dec 24, 2014 11:47 am

you helped me indeed!! Thanks a lot, the 32 bit version is working!
B
12
S
3
G
1
Posts: 46
Reputation: 1,518

Post » Wed Dec 24, 2014 4:38 pm

I get this samecrash on the 64bit version. I've found that resetting my layout preferences works. It might be related to dual monitors because the crash usually comes back when I move some windows to the other monitor. my drivers are updated to latest.
Edit: more info
I'm on win 7 with a geforce 760. The 32 bit version of construct also fixes the crash for me.
B
80
S
52
G
42
Posts: 370
Reputation: 26,330

Post » Sat Jan 10, 2015 1:51 pm

UberLou, yes it may be related. I also got dual monitors, so It may have something to do with it.
B
10
S
2
G
1
Posts: 48
Reputation: 1,265


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests