C3 beta doesn't load w/ latest Chrome + WebGL enabled

Post » Tue Mar 28, 2017 6:12 pm

While attempting to launch C3, I ultimately get a message that states,

Oops! WebGL is not supported.
WebGL provides high-performance graphics for web apps. Construct 3 needs WebGL support to run, but this browser does not appear to support WebGL.
Try installing any available system updates, and check for an update for your graphics driver. Alternatively if you have access to a newer device try using that.


I have ensured that I updated my Chrome browser to the latest available version at this time (Version 57.0.2987.110 (64-bit)) but still I either get the above message, or, on repeated attempts, a page that says the page doesn't even exist on the server according to the link that took me there (but this is seemingly random as other attempts will get me to the next page...but that's a separate issue with the Construct.net website). On the System Requirements Check page, however, it says, "Congratulations! As far as we can tell, you're able to run Construct 3!" So at this point, I'm not sure if it's my computer or a bug in C3 or the website, itself.

If it at all helps, here are my basic computer specs...
Acer Aspire 5349
Windows 10 Home OS
Intel Celeron CPU B800 @ 1.5GHz
8.00 GB RAM
64-bit OS, x64-based processor
(No dedicated graphics processor.)
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
139
S
22
G
8
Posts: 774
Reputation: 14,822

Post » Tue Mar 28, 2017 8:42 pm

I had the same problem on my notebook. Chrome said only software rendering is enabled under chrome://gpu/ . I managed to solve it by turning on the #ignore-gpu-blacklist flag under chrome://flags/ .

@Ashley I'm not sure you can do anything about this problem, but some solution is required for users who have their GPUs blacklisted (like it seems I had my i3-3110M's integrated GPU). Maybe a list of the steps they'd need to make in order to enable that flag on the "Oops! WebGL is not supported." page.
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,715

Post » Wed Mar 29, 2017 8:07 am

glerikud wrote:I had the same problem on my notebook. Chrome said only software rendering is enabled under chrome://gpu/ . I managed to solve it by turning on the #ignore-gpu-blacklist flag under chrome://flags/ .


Thank you for the tip!
Sadly, it didn't work. I engaged the #ignore-gpu-blacklist flag AND cleared the browsing history, cached items, cookies, etc. It still gives me the same error page I reported above.
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
139
S
22
G
8
Posts: 774
Reputation: 14,822

Post » Wed Mar 29, 2017 8:17 am

Also, I tried loading Construct 3 in my Chrome mobile browser directly through construct.net. Despite triple-verifying that I do, indeed, have the (currently) latest version (56), the page still acts like I'm on a desktop (I guess that makes sense...) and asks me to update to version 57.
I'm using the Google Pixel (Android version 7.1.1 with security patch level: March 5, 2017).
EVERYTHING is as up-to-date as I can figure.

I'm clueless about any Chrome settings regarding WebGL or my (non-existent) GPU.
Granted, this is all beta, but I don't know if this is because it's beta or if it's my computer.
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
139
S
22
G
8
Posts: 774
Reputation: 14,822

Post » Wed Mar 29, 2017 8:29 am

Try setting the WebGL2 flag to Enabled (it's Automatic on default).
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,715

Post » Wed Mar 29, 2017 8:50 am

Rhindon wrote: Despite triple-verifying that I do, indeed, have the (currently) latest version (56), the page still acts like I'm on a desktop (I guess that makes sense...) and asks me to update to version 57.


You can use it on Android, but you need to install "Chrome Canary" (it works in parallel to your regular chrome install and does not replace or break it). The regular one won't work yet, because it still is, as you said, at 56 which won't work with C3.

I tried it on Canary on a Pixel XL and it runs. Whether it makes sense to run it on that is an entirely different discussion ;)
B
73
S
28
G
32
Posts: 480
Reputation: 19,671

Post » Wed Mar 29, 2017 9:06 am

Please check the steps in this bug report : https://www.scirra.com/forum/oops-webgl-is-not-supported_t189525.
Consider posting your own results in the topic.

Reporting issues for C3 should be done in the bug reports forums, not the general discussion forums, thanks.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
289
S
112
G
94
Posts: 7,333
Reputation: 69,287

Post » Wed Mar 29, 2017 6:52 pm

Kyatric wrote:Please check the steps in this bug report : https://www.scirra.com/forum/oops-webgl-is-not-supported_t189525.
Consider posting your own results in the topic.

Reporting issues for C3 should be done in the bug reports forums, not the general discussion forums, thanks.


Sorry about that, @Kyatric. From the construct.net page, when it provided a link for reporting bugs, it took me to the general C3 discussion sub-forum. I didn't see the bug report forum for C3. I'll go ahead and repost this matter correctly.

And thanks everyone!
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
139
S
22
G
8
Posts: 774
Reputation: 14,822

Post » Wed Mar 29, 2017 7:00 pm

glerikud wrote:Try setting the WebGL2 flag to Enabled (it's Automatic on default).

Already done. That was one of the first things I did - by your suggestion, if I recall.
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
139
S
22
G
8
Posts: 774
Reputation: 14,822

Post » Wed Mar 29, 2017 9:17 pm

Rhindon wrote:Already done. That was one of the first things I did - by your suggestion, if I recall.

No, that was the to ignore the GPU blacklist. For WebGL2 I had a separate flag.
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,715

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests