Caching issues and how does/can it work?

Discussion and feedback on Construct 2

Post » Sun Jul 20, 2014 6:26 pm

The past three versions I've released of my game on my website have worked as expected, with some oddities related to caching.

First release went well. I pushed the game to my web server with no issues; the sound played back correctly and the game was intact as expected, and as played by my friends.

The second release was strange; one of my friends had a half-version where the button from the old version was shown, but the mechanics of the game itself along with all other graphics were correct. This was the only reported issue, and fixed when his browser cache was cleared.

The third release I had the most issues with; all my friends who had played one of the two previous versions on the same browser as last they used had to either clear the cache or use their browsers private browsing, which doesn't utilize any previously cached data, if I'm not mistaken. However, clearing the cache often resulted in another half-version of something screwed up.

For instance, in that third version, when I navigated to my game after clearing the cache (since it wouldn't download the new version without doing so), my button graphic's third frame was supposed to play, on click, but instead turned into a half-one-frame and half-another, correctly sized, but odd-looking. This was reported by my GF on her browser, and we both use Google Chrome.

One other friend (the one who composed my music) was claiming that there was an unusual audio click during music playback (and no other issues), which he recognized right away. Turns out that while using private browsing he could hear the correct audio.

Another friend said that sound effects weren't playing, on Safari on his iPad, but worked correctly using a different browser on that same device. He hadn't ran the game before, so I know it's an audio issue, and after running the game that first time, it worked correctly, which points me right back at caching.

All three versions had different project version numbers, if that helps. Preview/debug always worked correctly.

So what's the big deal with caching, and/or how do I avoid it or force browsers to re-download all new files? Because it certainly is not working correctly.
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826

Post » Sun Jul 20, 2014 6:45 pm

If you want to force the redownload of everything (which also will disable offline support), delete the offline.appcache, of course this is only a temporary solution as this problem should be corrected.
Game design is all about decomposing the core of your game so it becomes simple instructions.
B
53
S
22
G
18
Posts: 2,122
Reputation: 17,123

Post » Thu Jul 24, 2014 8:59 pm

@Aphrodite I realized I never replied. Thanks for tip. I will await a fix. : )
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,826


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 7 guests