Can't do Danish letters: , ,

Discussion and feedback on Construct 2

Post » Sat Jul 06, 2013 2:31 pm

Hello.

When I'm previewing my layout, the text is showing wrong.
It shows wrong signs for the letters: , and .

The text is located in project/files/questions.txt
as questions for a trivia game.

What shall I do? Can somebody please help.
B
3
Posts: 4
Reputation: 183

Post » Sat Jul 06, 2013 4:00 pm

Are you using the text object or sprite font object? If the text object, what font are you using?
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,930

Post » Sat Jul 06, 2013 5:11 pm

I am using the text object. The font is Arial.
B
3
Posts: 4
Reputation: 183

Post » Sat Jul 06, 2013 8:20 pm

This is working for me: .capx.
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,930

Post » Sat Jul 06, 2013 9:27 pm

Thanks a lot for your answer.

I am working on a trivia game using the template found here:

http://www.scirra.com/forum/making-a-quiz-game_topic50656_page2&SID=9ez751d4-1c68-956da1b2-41461-8838425926.html

I still have the problem, when I put in " and " in the text file (Questions.txt) and loads the text through AJAX.

Best regards

/MHv



B
3
Posts: 4
Reputation: 183

Post » Sun Jul 07, 2013 8:51 am

File a bug report if you're having problems with what should work normally. Just make a CAPX showing it works normally (text object) and that when loading from AJAX, strings display properly except those characters.

B
21
S
8
G
6
Posts: 346
Reputation: 4,891

Post » Sun Jul 07, 2013 9:55 am

Well, before reporting a bug make sure if there isn't an issue with the txt file, it's maybe its encoding that is wrong.
Maybe try to save the .txt to UTF or something like unicode to see if the issue does not come from there.

@Ashley would you have an idea about this ?
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
292
S
115
G
96
Posts: 7,295
Reputation: 70,795

Post » Sun Jul 07, 2013 12:03 pm

Construct 2 fully supports unicode. You're probably saving the .txt file with the wrong encoding. Make sure you save it with UTF-8. If you save it as ASCII, non-english characters will appear as the wrong characters, which explains the issue.
Scirra Founder
B
398
S
236
G
88
Posts: 24,441
Reputation: 194,661

Post » Mon Jul 22, 2013 7:12 pm

Problem fixed. Thanks a lot guys!

The text file was saved with the wrong encoding.
B
3
Posts: 4
Reputation: 183


Return to Construct 2 General

Who is online

Users browsing this forum: Tjums and 14 guests