Can't load my game / error / crash [Solved]

Bugs will be moved here once resolved.

Post » Sun Nov 27, 2011 3:03 am

Was working on my game, went to preview, got an error. I didn't mind it and just restarted C2. Now I can't load my game. I get the following error and then C2 crashes.

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find project file for animation frame

Condition: FileExists(GetProjectPath().c_str())
File: Projects\AnimationFrame.cpp
Line: 188
Function: void __cdecl AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 69 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------


Please help! I can PM the .capx if necessary.

Also, if I click retry or ignore then C2 doesn't crash, but I get like 3 other errors. 1 refers to a possibly corrupted .png used in one of my background objects. I didn't understand the others.

I have a previous version I can restore but it's about 3 days old. There's quite a bit missing. (I should start working slower :P) Also there's no guarantee I won't end up getting the same error a while after restoring it, right?
Tokinsom2011-11-27 15:12:02
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024

Post » Sun Nov 27, 2011 2:27 pm

Send me your .capx and I can recover it, can you remember what you did immediately before this happened?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Sun Nov 27, 2011 2:38 pm

Dunno exactly how much info you need, so here's exactly what I did a few minutes before the error started appearing.

I had just started on the winter level ("Level_4" layout name). I had copied over some essential objects from Level_1. I then added a level image from Tiled. For some odd reason its size made C2 distort the image in the preview, so I deleted it, resized the image, then added it again. I then went to add the music (Level_1_Intro , Level_1_Main) but discovered I already did that, so I deleted the duplicates. I then added the events to play & loop the music at the start of the layout, then went to preview.

It was at this time I got an error and the preview wouldn't load. I think I just lost my internet connection so I shrugged it off, saved my project, and closed C2. When I went to open it later I got the error I posted above and now the game won't load.

Sending you the .capx now. Thanks for looking into it!
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024

Post » Sun Nov 27, 2011 4:26 pm

The title says "Solved", what was the problem?
ImageImage
B
25
S
6
G
8
Posts: 773
Reputation: 6,643

Post » Sun Nov 27, 2011 4:54 pm

Seems some animation frames for one of my objects got corrupted or something and were removed. All I had to do was click "Retry" which let me bypass the errors and replace the animation frames.

One of the errors referred to a possibly corrupted .png used by 'bird', which was the affected object. Keep that in mind if this ever happens to you!

Thanks again to Ashley for figuring this out.Tokinsom2011-11-27 17:03:03
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests