Cannot find project file for animation

Bugs will be moved here once resolved.

Post » Wed Dec 14, 2011 7:23 am

I saved my project yesterday. When opening it today I get the following error. Its a self contained project (one file).

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find project file for animation frame

Condition: FileExists(GetProjectPath().c_str())
File: Projects\AnimationFrame.cpp
Line: 188
Function: void __thiscall AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 70 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

I click ignore:

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Setting texture, but texture file on disk appears to be missing

Condition: FileExists(GetActivePath().c_str())
File: Projects\ObjectTexture.cpp
Line: 372
Function: void __thiscall ObjectTexture::GLEnsureLoaded(struct ObjectTexture::GLTextureInstance *)
Build: release 70 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

ignore again:

---------------------------
Failed to load texture
---------------------------
Error loading texture 'C:\Users\win2go\AppData\Local\Temp\cap19CG1Y\Animations\Baracks\Default\000.png': Failed to read image file data
This may indicate a corrupt PNG file in the project directory. The image will not be able to be displayed in the editor.
---------------------------
OK   
---------------------------


B
32
S
7
G
6
Posts: 34
Reputation: 4,790

Post » Wed Dec 14, 2011 4:13 pm

How come you're still on r70? I tried to improve this in r71, so a report from r70 isn't really very useful...
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Wed Dec 14, 2011 4:27 pm

Can't say for sure, usually I upgrade each time it reminds me on startup. Maybe I dismissed the message once (can't remember) and therefore it doesn't popup again?
I tried the project again but no change (luckily it was not very important), so maybe with 71 it would not have become corrupted. I'll post again if it happens to me with the latest version (on another project).

B
32
S
7
G
6
Posts: 34
Reputation: 4,790

Post » Wed Dec 14, 2011 4:30 pm

BTW if you ignore every message or click Retry the project should load OK. You'll need to find an object with a missing image though and replace it.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Wed Dec 14, 2011 5:21 pm

Thanks, I could fix it...
B
32
S
7
G
6
Posts: 34
Reputation: 4,790


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests