Cannot read property 'ǃws' of undefined

All closed bug reports are moved here.

Post » Mon Apr 03, 2017 12:24 pm

[edit]: Thought it was on mobile only. Apparently it happens on PC too even if there is connection. Some templates works and some don't.

Issue: Can't give a "stall" request and get retries like on PC. It just crash if connection is off.
Steps to reproduce: Download any template and cut the WiFi connection.

MOBILE
Error report information
Type: unhandled rejection
Reason: TypeError: Cannot read property 'ǃws' of undefined
Construct 3 version: r14
URL: https://editor.construct.net/
Date: Mon Apr 03 2017 20:15:39 GMT+0800 (MYT)
Uptime: 23 s

Platform information
Browser: Chrome
Browser version: 58.0.3029.42
Browser engine: Blink
Browser architecture: 32-bit
Context: browser
Operating system: Android
Operating system version: 6.0
Operating system architecture: 32-bit
Device type: mobile
Device pixel ratio: 2
Logical CPU cores: 4
User agent: Mozilla/5.0 (Linux; Android 6.0; U FEEL Build/MRA58K) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.42 Mobile Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: ARM
Renderer: Mali-T720
Major performance caveat: no
Maximum texture size: 4096
Point size range: 1 to 1024
Extensions: EXT_disjoint_timer_query_webgl2, WEBGL_compressed_texture_astc, WEBGL_compressed_texture_etc, WEBGL_compressed_texture_etc1, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context

PC
Error report information
Type: unhandled rejection
Reason: TypeError: Cannot read property 'ǃws' of undefined
Construct 3 version: r14
URL: https://editor.construct.net/
Date: Mon Apr 03 2017 20:45:19 GMT+0800 (Malay Peninsula Standard Time)
Uptime: 5.7 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 64-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1.25
Logical CPU cores: 8
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Mon Apr 03, 2017 2:04 pm

Ah yeah looks like it isn't handling the download error correctly, it just decided to plough on even though it hadn't managed to load the project. Should now display the actual failure message, instead of crashing.
Scirra Employee
B
6
S
2
Posts: 135
Reputation: 928


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests