Can't figure out how to change the color filter properly

For questions about using Classic.

Post » Wed Apr 20, 2011 8:34 am

Hello.
I'm making a simple "move-the-boxes-to-the-right-spots" game (I think it's called Soukoban in Japanese). I'm using a simple tutorial by Minor78 as an example of how to make it so I can save my levels as small BMP pictures and then load them as a level in the game.

I'm stuck at a certain point. I have some sprites where I need to change their color. My problem is that if I, in my game, select the same option as in the tutorial I can only select a color and define the RGB values. I can't seem to get it to let me use an expression like in the tutorial.

I've included a screenshot of my game on my left screen, and the tutorial on the right.

[url:2oi94mh5]http://dl.dropbox.com/u/2776515/construct%20-%20colorFilter.png[/url:2oi94mh5]
B
3
G
2
Posts: 11
Reputation: 697

Post » Wed Apr 20, 2011 8:40 am

I found out what my problem was. In case anyone else runs into this problem, simply right click on Filter and choose "Use expression" :mrgreen:
B
3
G
2
Posts: 11
Reputation: 697

Post » Wed Apr 20, 2011 11:14 am

It is always a good idea to have a look at the wiki:
http://sourceforge.net/apps/mediawiki/c ... n_features

It doesn't answer every question but still really helps a lot, so go bookmark the wiki :)
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Wed Apr 20, 2011 2:33 pm

I had the same issue until recently. It opens up a whole new world of possibilities once you find out you can add expressions
B
10
S
4
G
5
Posts: 136
Reputation: 2,977


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 7 guests