Can't get the Advanced Camera Object to scroll

For questions about using Classic.

Post » Tue Mar 09, 2010 8:15 am

http://junk.drule.net/fjalar%200.1.cap

Simply put, anyone know why this won't scroll? I'm using the following events:

On start:
Create camera "Main" at player.X and player.Y and Zoom to 200. Follow.
Camera "Main" follow player
Switch to camera "Main"

Thanks in advance.
B
2
S
1
G
3
Posts: 71
Reputation: 1,142

Post » Tue Mar 09, 2010 12:36 pm

Updated from version 0.8b to 0.9 which seemed to fix it. This was a weird problem as I've successfully made scrolling platformers using version 0.8b before.

As a side note though, anyone knows how to disable the unbound scrolling which seems to be applied by default on this version of the Advanced Camera Plugin?
B
2
S
1
G
3
Posts: 71
Reputation: 1,142

Post » Tue Mar 09, 2010 2:09 pm

Hey Drule, you should update your Advanced Camera once again to version 0.92b if you didn't already. There are margin settings for the follow action which could help with your problem.
B
21
S
6
G
10
Posts: 1,024
Reputation: 7,440

Post » Tue Mar 09, 2010 4:17 pm

[quote="PixelRebirth":1k7b4nbx]Hey Drule, you should update your Advanced Camera once again to version 0.92b if you didn't already. There are margin settings for the follow action which could help with your problem.[/quote:1k7b4nbx]
When was version 0.92b released?
I can't seem to find it anywhere here.

Krush.
B
2
S
2
G
3
Posts: 406
Reputation: 2,062

Post » Tue Mar 09, 2010 4:56 pm

[quote="Drule":1usp2lpg]As a side note though, anyone knows how to disable the unbound scrolling which seems to be applied by default on this version of the Advanced Camera Plugin?[/quote:1usp2lpg]
If you click on the camera object in the object bar while in the layout editor you'll see a "Bind to layout" checkbox in the properties pane on the left. Checking this will disable unbounded scrolling.

[quote="KrushBrother":1usp2lpg]When was version 0.92b released?
I can't seem to find it anywhere here.[/quote:1usp2lpg]
Here it is. :)
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Post » Tue Mar 09, 2010 5:10 pm

[quote="linkman2004":1c2d09eq]If you click on the camera object in the object bar while in the layout editor you'll see a "Bind to layout" checkbox in the properties pane on the left. Checking this will disable unbounded scrolling.
[/quote:1c2d09eq]

Ah, so that's what "Bind to layout" does... :)
Good to know!

Although it doesn't seem to take zoom into account. So if it's like in your cap with layout and window the same size, there will still be no place to scroll.
B
21
S
6
G
10
Posts: 1,024
Reputation: 7,440

Post » Tue Mar 09, 2010 5:51 pm

[quote="linkman2004":7in1djoa]Here it is. :)[/quote:7in1djoa]
Damn.
I do have that one.

I was hoping I didn't, so it might fix the non-scrolling problem I was having with it:

[color=#BF0000:7in1djoa]http://www.scirra.com/forum/viewtopic.php?f=2&t=4687&hilit=advanced&start=110#p46351[/color:7in1djoa]

Thanks anyway,
Krush.
B
2
S
2
G
3
Posts: 406
Reputation: 2,062

Post » Tue Mar 09, 2010 11:13 pm

[quote="linkman2004":q5l3oftl][quote="Drule":q5l3oftl]As a side note though, anyone knows how to disable the unbound scrolling which seems to be applied by default on this version of the Advanced Camera Plugin?[/quote:q5l3oftl]
If you click on the camera object in the object bar while in the layout editor you'll see a "Bind to layout" checkbox in the properties pane on the left. Checking this will disable unbounded scrolling.[/quote:q5l3oftl]
Enabling "bind to layout" once again disables the scrolling. Is it just me, or is anyone else experiencing problems with the .cap I provided? For some reason it just won't scroll at 200% zoom unless I unbind the scrolling.
B
2
S
1
G
3
Posts: 71
Reputation: 1,142

Post » Tue Mar 09, 2010 11:45 pm

Im getting something like that on rotation with zooming when it gets to 200%.
Image Image
B
161
S
48
G
89
Posts: 7,345
Reputation: 66,245

Post » Wed Mar 10, 2010 4:39 am

[quote="Drule":6357a3jw]Enabling "bind to layout" once again disables the scrolling. Is it just me, or is anyone else experiencing problems with the .cap I provided? For some reason it just won't scroll at 200% zoom unless I unbind the scrolling.[/quote:6357a3jw]
As PixelRebirth brought up it's not taking zoom into account for the layout binding. I know how to fix it, but I won't be able to get around to it for a while.

In the meantime, you can use uniform size grid scrolling to simulate proper binding. Just set the area size to the size of your window and set it to follow your player object and it should work fine. Also, make sure to keep layout binding off.
Moderator
B
97
S
36
G
19
Posts: 1,584
Reputation: 17,692

Next

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 1 guest