Cant Launch C2

Discussion and feedback on Construct 2

Post » Wed Dec 30, 2015 8:50 am

i suppose that's a steam installation?

have you tried downloading installer from site and installing?




p.s. you've got 6.2 GB of processes - that's... too much XD i mean it's ok because you got 32 GB of ram, but do you really need all that?

here's some i've noticed that could be removed (if you're not using them (i'll compare to mine)):
- akamai session
- bluetooth
- bonjour
- chrome cleanup ?
- display fusion (why are you using this on win10?)
- dropbox update
- geforce experience
- intel management services - they are all useless (as much as i've tried and looked they didn't do much, they just get in the way)
- itunes / ipod helper (unless you have iSomething)
- java updater
- msi afterburner (i suppose you're overclocking )
- nvidia driver + network services
- bandwidth meter?
- sierra service?
- skype updates

now i suppose you've got this all installed and you're using most of it, but if you're not just uninstall all unneeded programs, most of them that "offer" performance and what not actually make your system work worse then it actually can and just slow it down. now you could run a spyware / virus check aswell as you might get suprised by some random unexpected thing.


i know what your answer probably will be: "but i need all these, i'm a programmer / designer / etc.." and that's fine if you work with it.

i've got my developer stuff on my pc installed (lots of it) but still i have less processes then you. (and i've got mercurial, visual studio, sqlserver, photoshop, loads of other tools, java, flash, etc.. ) they all have their processes but i've terminated them all, since i prefer manual work mostly. (most secure and fastest in execution).

p.s. also check your startup programs there might be some wierd things too. disable unneeded.

also someone mentioned ccleaner registry cleaning. try this:
uninstall c2,nwjs, clean appdata for c2, and run ccleaner, but beforehand install ccenhancer. (make sure you tick everything (except maybe browser history / session / passwords, and the things that pop up a window) and clean your drive aswelll. then run cc registry clean.

cc registry clean is pretty shallow, so i'd recommend you install wise registry cleaner. make sure in options you select "deep" cleaning and select "back up registy before cleaning", i think it's on by default. clean registry with this tool. you can also compress it with defrag for higher performance (it will restart your pc).
then try installing stable and check if it works.

if nothing helped sofar - it might be that your UAC (if you have it ON) is causing problems when running app.
also - open event viewer and check application logs. if there are yellow/red logs, try finding one with construct2.exe and details about the error. paste here.

windows shouldn't be a problem, i've been updating from 10240 to 10586 + all the new updates - and everything works ok.
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
39
S
14
G
12
Posts: 617
Reputation: 9,297

Post » Wed Dec 30, 2015 1:02 pm

I've never heard of this problem before. All I can suggest is open regedit and delete the entire key HKEY_CURRENT_USER\SOFTWARE\Scirra\Construct2. That will reset all settings. If that doesn't help, I'm not sure what it could be...
Scirra Founder
B
382
S
223
G
86
Posts: 23,998
Reputation: 189,773

Post » Fri Jan 01, 2016 3:37 am

Good news! The problem has been fixed.

tried everything you guys said and then some. Almost decided to give up or do a clean windows install.
In the end...

I'm assuming my geforce experience/my graphics drivers were the cause. Corrupted damaged who knows. Going through all my folders to delete and free up space, removing unwanted things... There were a handful of drivers/downloaded files in my nvidia folders, so i deleted and tried doing a fresh install on that. Still using the same driver build but C2 works now. Might have been some issue from going from a previous driver. I tend to run beta drivers so honestly cant say the underlying cause. My current driver is not even beta.
C2 was the only program being affected which I find very odd. Oh well...

Thanks for the help!
B
28
S
8
G
1
Posts: 226
Reputation: 2,865

Post » Sat Jan 02, 2016 3:15 am

well its a new day and a new year! Sadly, the issue came back so I really dont know what to do for an actual solution to whatever is going on.

switched to windows build 1511 (KB3116278)
Everything seems to be working now. So I dont believe it was actually a graphic driver issue.

Hopefully this is the complete fix.
B
28
S
8
G
1
Posts: 226
Reputation: 2,865

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Koalla, Ticket Games, Yahoo [Bot] and 9 guests