Can't open package.appxmanifest in VS2015

Bugs will be moved here once resolved.

Post » Thu Sep 03, 2015 9:16 am

@michael, it seems to work fine full screen to me. Not sure what running the deployment package is? I'm not using in game purchase so I can't tell about that.
B
8
S
1
Posts: 61
Reputation: 578

Post » Sat Sep 05, 2015 10:51 am

paula22 wrote:@michael, it seems to work fine full screen to me. Not sure what running the deployment package is? I'm not using in game purchase so I can't tell about that.


@paula22, interesting. When I run the game via vs there is no option to go fullscreen at all, I can max the window but there is no resize arrow to tell it to go full screen, so I get the title bar and task bar.

As for the package: When you create your app package, you get the option to build the packages to upload to the store. If you select 'No' it builds debug packages and places them in a folder location of choice. That folder contains an Add-AppDevPackage file. So you can right click the file and choose 'run with powershell', and it installs the package (also called side-loading). Just another way to test it out without any vs overhead before uploading to the store.
If it can be done, someone on the web will show you how to do it!

CDASI Games Mentality Break Splat-a-bug FlapFleet Challenge
B
34
S
12
G
7
Posts: 356
Reputation: 7,144

Post » Tue Sep 08, 2015 3:49 pm

The only issue I can reproduce is if you leave any of the project ID, version, author or description fields empty, these get left empty in package.appxmanifest and cause VS2015 to say the file is invalid. In the next beta C2 now prompts for these to be filled in if exporting for Windows 10 which should prevent this happening. I believe all other issues are either just having the wrong components of VS2015 installed, or are otherwise unrelated, so please file separate issues for those if you still have trouble and are certain you have VS2015 installed correctly and have filled out the project ID, version, author and description fields.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Sat Nov 21, 2015 4:27 pm

Hi, i'm having the same problem. All my project fields are filled, but i'm not sure what to use in ID, if is required a specific value or string, but anyways i filled with my company name. Please let me know if this is not right. Another thing, can someone tell me what components should be installed on VS2015, cause i have just downloaded it from microsoft and that is it. If i'm missing something, please let me know as well.

Thanks in advance!
B
14
S
5
Posts: 110
Reputation: 1,338

Post » Tue Dec 22, 2015 6:02 pm

I get this error when trying to do the same thing:

Severity Code Description Project File Line Suppression State
Error APPX0501 Validation error. error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 10, Column 57, Reason: '1.0' violates pattern constraint of '(0|[1-9][0-9]{0,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])(\.(0|[1-9][0-9]{0,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])){3}'. The attribute 'Version' with value '1.0' failed to parse. NewProject C:\Users\rmagie\Desktop\New project\bin\Debug\AppxManifest.xml 1
B
7
Posts: 6
Reputation: 294

Post » Tue Dec 22, 2015 8:52 pm

I figured it out guys.

OK, two things I did that fixed this issue for me. The first one was in Visual Studios you need to change the version to 1.0.0.0 or whatever version you have on the appxmanifest file. I had mine as just 1.0 so I changed it to 1.0.0.0 , Visual Studios needs you to have a format of x.x.x.x and that fixed the first part. The 2nd part for me was the ID. You need to change the ID to com.mycompany.myapp and that should make it work. For example My id used to be 1 so I changed the ID to com.saltygamer.game Another easy way to fix this is doing it inside the project properties of construct 2 before you export. I hope this helps you.
B
7
Posts: 6
Reputation: 294

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests