Can't re-join room after leaving [Signalling Server Issue]

Discussion and feedback on Construct 2

Post » Fri Nov 13, 2015 1:55 am

Hello, I'm a recent purchaser of Construct 2 and I'm continuing my learning process by making a party game.

Currently, the offline version is working as intended (for the most part), however while I was working on the chat room for the online pre-game lobby I encountered a weird bug. I followed this guide https://www.scirra.com/tutorials/906/multiplayer-tutorial-2-chat-room/page-4, and the bug with my lobby is that if you join the lobby, then leave, via the menu button, you can not rejoin without closing the game and opening it back up.

Events for Signalling Server:
Image

Logging in the first time:
Image

Chat Room first time (works):
Image

After exiting via the Menu button, trying to connect to the server again:
Image
Image

You can still leave to the main menu but you can not reconnect, even if you type in the same name at the log in screen.

Thanks in advance for any help solving this issue.
B
4
Posts: 3
Reputation: 206

Post » Fri Nov 13, 2015 1:59 am

Try making it so that you completely disconnect from the signalling server when you click the main menu problem. That's how I solved my lobby issues.
B
12
S
3
Posts: 68
Reputation: 906

Post » Fri Nov 13, 2015 2:17 am

Sorry, could you explain what that means? I thought that "Disconnect from room" action already did this? Is there a better Action?
B
4
Posts: 3
Reputation: 206

Post » Fri Nov 13, 2015 2:18 am

Never mind, found it! Thanks for the answer. For future reference, needed to change "Disconnect from room." to "Disconnect from signalling server." Whoops.
B
4
Posts: 3
Reputation: 206


Return to Construct 2 General

Who is online

Users browsing this forum: mihirolover, Tjums and 10 guests