Can´t start C2, missing DLL-file

Discussion and feedback on Construct 2

Post » Mon Jun 13, 2016 6:52 am

Hi all!

Since about a week I´m having troubles starting C2 (version r227) due to an error that says something like (translated from Swedish):
"Can´t start the program since ÿÿ•.dll is missing. Try to reinstall the program"

I have tried to google that weird file name but don´t get any hits.
I´ve tried to reinstall C2 several times but sadly the problem persists.

Two weird things though:

1) If I try a newer version (beta 228 or 229) a get a slightly different error message:
"Can´t find procedure entry point • in DLL-file KERNEL32.dll"

2) When I reinstall the program (any version) and choose "Launch after installation", C2 starts just fine everytime.
But if I close it and then try to start it the "normal" way (by clicking the icon on the desktop or in the folder) I get the above messages.


Apart from reinstalling I have:
- made several virus scans (that came up with nothing)
- run the sfc/scannow, which said everything was fine
- checked that I have the latest graphics drivers
- searched the forums here, and some kernel32-problems seem to have arisen in the past, but usually they have been solved when a later C2-version is released.
- checked that I have the latest Google Chrome version

Any suggestions what else I could try?


EDIT: I´m on Windows 7, 64-bit.
Last edited by mindragon73 on Mon Jun 13, 2016 11:46 am, edited 1 time in total.
B
27
S
7
G
4
Posts: 20
Reputation: 3,794

Post » Mon Jun 13, 2016 7:31 am

Something very amiss with your pc I think.

A really good scan with Malwarebytes and a good AV would be my first course of action, as something is messing with your files, it seems to me.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,379
Reputation: 58,440

Post » Mon Jun 13, 2016 8:43 am

Hi!

Thanks for the answer!
I´ve done several scans, including one with Malwarebytes, but haven´t found anything yet.

So far I don´t have problems with any other programs.
But as I wrote, C2 will launch immediately after reinstallation if i choose the option "Launch after installation", but not when starting it by clicking the icon or exe-file.
Isn´t that strange?
B
27
S
7
G
4
Posts: 20
Reputation: 3,794

Post » Mon Jun 13, 2016 12:44 pm

Try running it as administrator.
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,717

Post » Mon Jun 13, 2016 12:52 pm

Hi!

Thanks for the tips!
I´ve tried running it as an administrator, and also installing it as an administrator, but still the same results unfortunately.
It´s annoying that the name of the dll-file is so strange that I can´t google it. :(
B
27
S
7
G
4
Posts: 20
Reputation: 3,794

Post » Mon Jun 13, 2016 1:21 pm

Update your windows to 8. It might be a file that the windows is missing to run Construct2 rather than Construct 2 missing something.
Check out my awesome Android Game releases https://play.google.com/store/apps/deve ... ames&hl=en
B
38
S
18
G
24
Posts: 681
Reputation: 16,613

Post » Mon Jun 13, 2016 2:02 pm

I had similar problems with one machine, run sfc /scannow at a command prompt, you may need to restart your system in console recovery mode.
B
17
S
4
G
5
Posts: 12
Reputation: 3,157

Post » Mon Jun 13, 2016 3:33 pm

Hi,

Pixel Power: I do not want Windows 8 or 10 :-)
davidochoa; I´ve run sfc /scannow at a command prompt (as administrator) but it says everything is fine.

I don´t actually think there is a problem with C2, but rather that I´m all of a sudden missing a dll-file or two (or have the wrong version). I just don´t know how to figure out which ones when the computer won´t give me a better error message than the ones I mentioned above.

I did a system restore to a point when I know for sure that C2 worked fine, but that didn´t help either.

I checked some other (non C2) forums for similar problems, and someone got the tip to run a tool called Dependancy Walker (http://www.dependencywalker.com/) to figure out what files were missing or corrupt,
i tried that, but I don´t really understand how to interpret the results there. And as I understand it the tool is kind of old and can give "false" results on newer windows versions.

But, all tips are welcome!
I really want to get back to working on my game again!
B
27
S
7
G
4
Posts: 20
Reputation: 3,794

Post » Tue Jun 14, 2016 8:38 am

I'm not entirely sure about this, but you could download the dll file and put it into the C2 install folder: https://www.dll-files.com/kernel32.dll.html
B
135
S
33
G
17
Posts: 1,557
Reputation: 20,717

Post » Tue Jun 14, 2016 9:11 am

As a gamer I believe your problem is with dll in WIndows 7 right ?
So go to microsoft website and download microsoft visual c++ latest version........
B
13
S
5
G
4
Posts: 119
Reputation: 3,353

Next

Return to Construct 2 General

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests