Canvas - "Draw Point" action only draws red channel?

For questions about using Classic.

Post » Sat Aug 14, 2010 1:13 pm

I might just be doing something wrong, but the "Draw Point" action for the Canvas object seems to treat the green and blue color components of the color parameter as zero, regardless of the color I pick.

That is, if I try to draw a white (255,255,255) point, I get a red (255,0,0) point.
Likewise a gray point (128,128,128), is drawn as a dark red (128,0,0) point.
A blue (0,0,255) point is drawn as a black (0,0,0) point.
It's as if the blue and green values are being discarded.

Am I just doing something wrong, or is this a known issue? I couldnt find another mention of it in the forums.
B
21
S
13
G
8
Posts: 306
Reputation: 5,458

Post » Sat Aug 14, 2010 3:12 pm

assuming your using "USE EXPRESSION" did you write RGB(255,255,255) or only (255,255,255) in the expression? assuming you didnt try it, put the RGB and see how the turns out.

if its happening while your using the colour box default thingy it might be a bug
B
52
S
7
G
6
Posts: 1,945
Reputation: 7,610

Post » Sat Aug 14, 2010 9:25 pm

I did try using RGB(rrr,ggg,bbb) expressions, and I got the same results. Interestingly, turning the opacity from 100 to 255, caused the points to display correctly for a few runs, but eventually I was back to only seeing the red channel. The "Draw line" and "Fill rectangle" actions seem to work fine for drawing points of any color though.
B
21
S
13
G
8
Posts: 306
Reputation: 5,458


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests