[CAPX added] TileMap flickers on movement when zoomed out

Report Construct 2 bugs here.

Post » Wed Jan 03, 2018 6:03 pm

UPD : Excuse me for being dumb and sending the .caproj instead of .capx. Has been fixed.

Problem Description
When layout is zoomed out, TileMap object renders differently from TileBackground - it's much more flickery and less smooth.

Attach a Capx
https://helldeveloper.weebly.com/uploads/6/0/6/6/6066363/tilemapbug.capx

Description of Capx
Press SPACE to move.
On the left there is TileBackground, looking good.
On the right there is TileMap, looking fiddly.

Steps to Reproduce Bug
  • Zoom out the layout
  • Move the sprite which has a ScrollTo behaviour

Observed Result
TileMap looks awful now.

Expected Result
TileMap looks as smooth as TileBackground

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
r250
B
6
S
3
Posts: 139
Reputation: 1,668

Post » Sun Jan 21, 2018 12:43 pm

a friend of mine with GTX1070 has also reported bad rendering on far zoomout.
Image
B
6
S
3
Posts: 139
Reputation: 1,668

Post » Wed Jan 24, 2018 3:57 pm

HellMax wrote:a friend of mine with GTX1070 has also reported bad rendering on far zoomout.
Image


Same issue here. I see it more on Intel embedded GPUs than nVidia, but it happens on both.
B
109
S
59
G
28
Posts: 570
Reputation: 24,646

Post » Wed Jan 24, 2018 8:40 pm

Some support at last! I've been trying to get this addressed for a while! Thanks :)
B
6
S
3
Posts: 139
Reputation: 1,668

Post » Thu Jan 25, 2018 4:14 am

Like I mentioned in another post, on my laptop the flickering is very minor. I have Intel HD 620 GPU.
I believe it's a hardware/driver issue..
Have you tried playing with project parameters like Enable WebGL, Sampling, Downscaling etc?
If I set "Fullscreen scaling=Low quality", then the tilemap flickering becomes much worse.
B
19
S
9
G
158
Posts: 2,404
Reputation: 84,435

Post » Thu Jan 25, 2018 10:42 am

dop2000 wrote:Like I mentioned in another post, on my laptop the flickering is very minor. I have Intel HD 620 GPU.
I believe it's a hardware/driver issue..
Have you tried playing with project parameters like Enable WebGL, Sampling, Downscaling etc?
If I set "Fullscreen scaling=Low quality", then the tilemap flickering becomes much worse.


I have acknowledged your comments on the issue and yes, there is correlation between graphic settings, hardware on different PCs and the amount of flicker, however it never fully goes away. That is why I submitted is as a bug.
B
6
S
3
Posts: 139
Reputation: 1,668


Return to Bugs

Who is online

Users browsing this forum: No registered users and 0 guests