Changing animation name doesn't update properties.

Bugs will be moved here once resolved.

Post » Mon Jun 12, 2017 6:25 pm

Problem Description
If you have an initial animation set in the properties bar of a sprite, then change the name of the animation in the sprite editor, the properties window doesn't update the name.
(I'm replacing a bunch of placeholder sprites, and it's a tad bit aggravating. They assemble a spaceship, and it's hard to see which ones changed to default. CornerWithConsole, EmptyCorner, CornerWithBed, etc. )

Attach a Capx
https://www.dropbox.com/s/qd3uxdcfu8rko ... .capx?dl=0

Description of Capx
Shows a sprite with two animations, you can rename "RedYellow", and see the property bar didn't update.

Steps to Reproduce Bug
  • in the layout view you can see the first frame of the "RedYellow" sprite.
  • Edit the sprite and change the name of Red/Yellow.

Observed Result
The sprite in the layout is now showing BlueGreen, because the name in the properties can't be found, and it's showing the default.

Expected Result
The initial animation name in properties would change with the sprite animation name change.

Affected Browsers
  • in editor only

Operating System and Service Pack
Win 10 creator

Construct 2 Version ID
r244
B
231
S
62
G
33
Posts: 902
Reputation: 40,348

Post » Mon Jun 26, 2017 11:44 am

This won't be fixed in C2 - the Sprite object in C2 only uses a normal text parameter for the initial animation name so there is no architecture for it to be updated when the animation is renamed. C3 uses a special parameter type, so it's fixed there. At this point we won't be backporting architectural changes to C2.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,772


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests