Check failure ; Cloning deleted object type

Bugs will be moved here once resolved.

Post » Sat Jul 16, 2011 6:29 pm

I can't seem to reproduce this bug report but I did get a log.

[code]---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cloning deleted object type

Condition: !IsDeleted()
File: Projects\ObjectType.cpp
Line: 445
Function: class std::unique_ptr<class ObjectType,struct
std::default_delete<class ObjectType> > __thiscall
ObjectType::Clone(void) const
Build: release 47.2 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)[/code]

I wasn't completely sure what I was doing to receive this report. I remember I was just figuring things; cloning a object, copying/pasting a object, and removing them. I did delete the object under "Object Types" folder then clicked something on the layout and poof, the check failure.

I tried to reproduce but it works like a peach though.

[code]OpenGL Information
Rendering with OpenGL 2.1.0 - Build 8.15.10.2202
Intel; Mobile(R) 4 Series Express Chipset Family
(shader language 1.20 - Intel Build 8.15.10.2202)

Window Vista 32-bit[/code]Aindra2011-07-16 18:37:05
B
8
S
1
G
1
Posts: 13
Reputation: 788

Post » Sat Jul 16, 2011 9:57 pm

Thanks for the report - that's really weird, it looks impossible in the code... I'll keep an eye out for similar reports.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,630


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests