Check Failure : Copy of events

Bugs will be moved here once resolved.

Post » Mon Jul 18, 2011 8:33 am

C2 r47-2; Windows XP; FireFox 5; ATI Radeon HD 4800

Steps that lead to the bug:

I was working on a project.
I saved my project in a new folder (created out of C2)
I created a new single object project.
I setted the size of my layout and project (to 800,600)
I copied a sprite (with an animation of 2 frames) from my first project to the new one.
Set it to x 200.
I selected a couple of events + 1 comment, copied (mouse and keyboard shortcut works the same) from the original project.
I went to the blank event sheet of my new project.
I right clicked to see if there was a paste option (I saw none)
I pressed Ctrl+v to paste

=> Check Failure
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Condition ID does not appear to exist in related plugin

Condition: plugin->HasConditionID(cnd_id)
File: Projects\EventCondition.cpp
Line: 36
Function: __thiscall EventCondition::EventCondition(class EventBlock &,class ObjectType *,class BehaviorType *,int,class std::vector<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> >,class std::allocator<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> > > > &&)
Build: release 47.2 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abandonner   Recommencer   Ignorer   
---------------------------


I ignored.
I optain an alert window : Failed to paste : the data on the clipboard does not appear to be valid

I then realized I was trying to copy code about an object not present on the new project (mouse object)
I added it and was able to copy/paste the events as usual.

***
I then tried to recreate the bug using the same steps.
I got the check failure again, this time I abandoned (first choice) and got another check failure :

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Object texture leak: a texture is still loaded when cleaning up an ObjectTexture, check all textures released properly

Condition: gl_instances.empty()
File: Projects\ObjectTexture.cpp
Line: 43
Function: __thiscall ObjectTexture::~ObjectTexture(void)
Build: release 47.2 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 6)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abandonner   Recommencer   Ignorer   
---------------------------

Another abandon and C2 exited.
Retry quits C2 too.
Ignore sends the same check failure again.
Cascade of ignoring ends in a crash of C2 with a windows OS alert "We're sorry, your software crashed, would you like to send us some datas" style. (XP)

This bug doesn't block the use of C2 (as long as you ignore the first check failure).
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Mon Jul 18, 2011 8:41 am

I will take the opportunity of this thread also to ask about another issue I encountered (not sure it is a bug, so if this post desserves a better place somewhere else on the forum, just move it)

mouseover.capx

C2 r47-2; Windows XP; FireFox 5; ATI Radeon HD 4800

My code is quite simple. When the cursor is above the sprite object "FR" the animation frame changes.
It does so.

The second event is intended to be "when cursor is not on sprite object "FR" " then the animation frame changes again to the previous one.

Nevertheless, when I remove the cursor from above my object in preview, the animation frame does not change.

I must be missing something (like some of my previous posts) so I am asking Ashley to enlighten me once again. :D
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Mon Jul 18, 2011 6:59 pm

First problem: copying and pasting events between projects isn't supported yet. Sorry - on the todo list.

Second problem: I think this is fixed in r48, it includes "[Fix] Inverted 'mouse over object' didn't work correctly". Can you check and confirm?Ashley2011-07-18 19:00:05
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Mon Jul 18, 2011 7:10 pm

[QUOTE=Ashley] First problem: copying and pasting events between projects isn't supported yet. Sorry - on the todo list.[/quote]

Well in the end I managed to. Once I had the same objects on the destination project as on the source project, copy/paste of events worked.

[QUOTE=Ashley] Second problem: I think this is fixed in r48, it includes "[Fix] Inverted 'mouse over object' didn't work correctly". Can you check and confirm?[/QUOTE]

Checked and confirmed sir. I tried the very same project in r48 and it worked as expected.
I suspected something about the invert condition.
Keep up the good work Ash. I guess this thread can go to closed bugs.Kyatric2011-07-18 19:11:06
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795


Return to Closed bugs

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests