Check failure in r76 when accessing LAN preview

Bugs will be moved here once resolved.

Post » Mon Jan 23, 2012 8:57 pm

Here are my system specs:
Windows XP SP3
Intel Centrino
Geforce 6800 Go
Chrome 17.0.963.38 beta-m
Construct 2 r76

The message itself:
Construct 2 Check failure
Check failure! This is probably a bug:

Cannot find file on disk to return over HTTP
File: C:\Documents and Settings\shaun\Local Settings\Temp\c2-2OUFKE\html5\preview.html
This can indicate project corruption - please notify Scirra of this problem with the steps you were doing immediately beforehand.

Condition: false
File: HttpFileServer.cpp
Line: 295
Function: void __thiscall HttpFileServer::ServerRespond(struct _HTTP_REQUEST_V2 *)
Build: release 76 (32-bit) checked
Component: HTML5 exporter
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
Abort   Retry   Ignore   

The project file:
Blank project


I did some testing to try to narrow down when this occurs, and I can get the problem to repro consistently. I've included the capx file that I did it with as well.

1. Open Construct
2. Create a new project (or open an old one, happened in either case for me)
3. Save it as a capx
4. F5 to Chrome window
5. Close Chrome
6. Close the Project in the Project tab but leave Construct running
7. Attempt to access the server from my iPad, although most likely any access will trigger it.
8. Construct 2 Check failure occurs

Construct seems to leave the web server open even after I close the Chrome window, close Chrome entirely, and/or close the project. The server only terminates after I completely close down Construct itself.

Hope this helps,
-- cacotigon
Posts: 232
Reputation: 6,099

Post » Mon Jan 30, 2012 9:34 pm

Thanks, this should be fixed in the next build.
Scirra Founder
Posts: 22,832
Reputation: 176,750

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests