Choose 4 random animation-frames to 4 sprites!

Get help using Construct 2

Post » Thu Apr 03, 2014 9:47 am

This ought to be easy, but I've hit a wall..

I just want each sprite to have different colors :-/
You do not have the required permissions to view the files attached to this post.
B
7
S
1
Posts: 43
Reputation: 1,052

Post » Thu Apr 03, 2014 10:27 am

Here you go.
You do not have the required permissions to view the files attached to this post.
You think you can do these things, but you can't, Nemo!
Just keep reading.
Just keep learning.
B
65
S
16
G
9
Posts: 1,429
Reputation: 12,708

Post » Thu Apr 03, 2014 12:38 pm

Oh.. so I guess it was the:
for each sprite *ORDER BY SPRITE.X DESCENDING*

- that I really needed - thanx a lot, you're a lifesaver..
B
7
S
1
Posts: 43
Reputation: 1,052

Post » Thu Apr 03, 2014 12:50 pm

engberg wrote:Oh.. so I guess it was the:
for each sprite *ORDER BY SPRITE.X DESCENDING*

- that I really needed - thanx a lot, you're a lifesaver..


Yip. And you're welcome.
You think you can do these things, but you can't, Nemo!
Just keep reading.
Just keep learning.
B
65
S
16
G
9
Posts: 1,429
Reputation: 12,708

Post » Thu Apr 03, 2014 1:47 pm

Bugger - I'm going to ask my next question here - and if that´s wrong, I'll make a new one..

I try to put in a "wait 2.0 sec" just before the "set animation.frame to tempNumber" - to have each one get a color with a 2 sec wait between - but nothing happens - does the wait function have other requirements?
B
7
S
1
Posts: 43
Reputation: 1,052

Post » Thu Apr 03, 2014 2:17 pm

engberg wrote:Bugger - I'm going to ask my next question here - and if that´s wrong, I'll make a new one..

I try to put in a "wait 2.0 sec" just before the "set animation.frame to tempNumber" - to have each one get a color with a 2 sec wait between - but nothing happens - does the wait function have other requirements?


Yeah, getting wait to work is hard.
You are looping, so...
Answer: -> System: wait loopindex seconds (this makes it wait 1 second)
You do not have the required permissions to view the files attached to this post.
You think you can do these things, but you can't, Nemo!
Just keep reading.
Just keep learning.
B
65
S
16
G
9
Posts: 1,429
Reputation: 12,708

Post » Thu Apr 03, 2014 2:57 pm

Thanx - it didn't work the first few times, but I made it!

I guess I don't quite understand the blank-sub-event structure yet..

But your quick suggestion, helped me make it work - thanks a lot.
B
7
S
1
Posts: 43
Reputation: 1,052

Post » Tue May 13, 2014 4:44 pm

hey!

DUTOIT just to say thanks because i was looking for something look a like.

thanks from portugal weee
yolinux
B
18
S
5
Posts: 19
Reputation: 1,545


Return to How do I....?

Who is online

Users browsing this forum: ChoosyZerk, jorgmaquoi and 60 guests