Choosing to enable or disable WebGL on startup

Get help using Construct 2

Post » Sun Oct 13, 2013 7:37 pm

I have a game that have an effect object that I use, and no matter how much I reduce the amount of checks and loops needed for it to run, it'll run fine on a Desktop PC with a reasonably sized CPU and a good GPU, but runs slow on an ultrabook with less than 2 GHz processor and a moderate GPU. I also have this issue if I have a WebGL enabled project with a few WebGL effects where it runs fine on the same desktop, but runs at less than 30 fps on the same ultrabook.

However, if I disable WebGL for the game, it runs smoothly on both machines. While it makes the effect object unusable (so I have it disabled), but I want this game to run on as many PCs as possible. The problem is that there is no action to disable WebGL.

I can understand why that isn't possible mid-game, so is there any way I can choose whether or not to Enable WebGL when I boot up the game, or at least a way to disable all effects, regardless of where they are?
B
24
S
5
G
1
Posts: 89
Reputation: 3,015

Post » Tue Dec 24, 2013 3:16 am

I HAVE THE SAME PROBLEM MATE...
B
14
S
4
G
2
Posts: 109
Reputation: 2,679

Post » Tue Dec 24, 2013 5:29 am

There isn't any feature that would support this. However you can go into the C2runtime.js and code in such a requirement if really needed. Or make a suggestion to Ashley to do such an option.
B
90
S
18
G
9
Posts: 2,455
Reputation: 15,018


Return to How do I....?

Who is online

Users browsing this forum: David181, dop2000, namaewayukidesu and 11 guests