Chrome 33 + WebGL performance

Discussion and feedback on Construct 2

Post » Thu Feb 20, 2014 7:10 pm

Hi all,

Coincidentally Google released Chrome 33 today, the same day we did our r163 update.

Previous betas changed the way we detect the very slow software-rendered WebGL mode in Chrome and some people reported worse performance. However Chrome 33 ought to support the new detection and ensure best performance for everyone.

Can anyone who was affected confirm that Chrome 33 now correctly falls back to canvas2d instead of using a really slow WebGL mode?
Scirra Founder
B
403
S
238
G
89
Posts: 24,660
Reputation: 196,167

Post » Thu Feb 20, 2014 8:23 pm

No noticeable slow down for me.
B
12
S
3
G
2
Posts: 110
Reputation: 2,435

Post » Thu Feb 20, 2014 9:23 pm

Argh - still getting software rendering here. :(

At this point I think you should release a 163.2 and reimplement the hack you had before to get it to avoid software rendering. I'm stuck on version 159 so I can keep using node webkit before it was switched to use chromium 32. :(
Moderator
B
95
S
34
G
33
Posts: 3,007
Reputation: 27,876

Post » Thu Feb 20, 2014 10:06 pm

After the update i loaded up my newest project (that was running fine yesterday) and performance was terrible. I just did the chrome beta update to 33 and it didn't fix the problem, however, I think I may be getting a couple of extra frames of speed. It's still not playable though.
B
4
Posts: 13
Reputation: 224

Post » Thu Feb 20, 2014 10:52 pm

@Arima - is that in the Chrome browser at v33 or just in node-webkit?
Scirra Founder
B
403
S
238
G
89
Posts: 24,660
Reputation: 196,167

Post » Thu Feb 20, 2014 11:40 pm

Sorry I wasn't clear, both chrome 33 and node webkit in 163 are affected by the performance problem, same as chrome 32. Chrome 33 has resulted in no improvement and I'm still getting single digit fps when fullscreened. I was able to get 60 fps before in chrome 31/node webkit r159.
Moderator
B
95
S
34
G
33
Posts: 3,007
Reputation: 27,876

Post » Fri Feb 21, 2014 12:07 am

My project Orbit has recently taken a bit of a nosedive in performance recently, even still on Chrome BETA 33, and as we haven't added anything that would substantially reduce performance, in fact we've been optimizing. I even went through every collision event to check overlapping collisions were at the top as I thought it was the new collision cells that was causing the problem.

It seems like a very recent thing for us, maybe over the last two weeks.
B
44
S
13
G
8
Posts: 622
Reputation: 7,417

Post » Fri Feb 21, 2014 1:53 am

Guess I've been lucky...no issues with 33 beta, upgrading to 33 stable right now. Hell, I didn't even have any issues with 32. Knock on wood... ;)
B
44
S
10
G
10
Posts: 1,106
Reputation: 9,202

Post » Fri Feb 21, 2014 6:36 am

Running Windows 8 64bit, with Chrome 33 (all chrome://flags in default) and r163 build. Chrome 33 browser defaults to webgl just fine. I have Configuration Enable WebGL On. At first it was defaulting to canvas2d and the FPS was at 36, but then I updated the GeForce drivers from 331.65 to 334.89 and it works great now. I'm getting a solid 60 FPS in both webgl and canvas2d with Chrome 33.
B
3
Posts: 3
Reputation: 216

Post » Fri Feb 21, 2014 1:50 pm

@Arima: for node-webkit, could you try this?

https://dl.dropboxusercontent.com/u/152 ... ackage.zip

Extract the two .json files over the ones in <install dir>\exporters\html5\node-webkit. They should add commandline switches to prevent using Swiftshader, so ideally you'll get fast canvas2d instead of slow webgl in node-webkit.

In the mean time I'm trying to find out from someone on the Chrome team if the new workaround should actually be working in Chrome 33 - I was told it ought to be working...
Scirra Founder
B
403
S
238
G
89
Posts: 24,660
Reputation: 196,167

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests