Chrome and Crosswalk App - Crash if loading ogg sounds.

Bugs will be moved here once resolved.

Post » Fri Oct 10, 2014 5:34 pm

Problem Description

-Tablet Model : F&U ETB7554 (4GB)-
Android 4.2.2
1024 x 600 pixels screen
RockChip - Dual Core: 1200 MHz
RAM: 1024 MB

Chrome for android run in preview and Crosswalk building apk, crash in my tablet, if loading ogg sounds on start. [TESTED] :cry:
if Delete ogg sounds from a sound folder, and i have only m4a sounds in sound folder, Works Fine ? :)

And if delete all sound from sound folder game run.
The music works great, and run in ogg file ?

What happens ? :cry: :cry: :cry:


Attach a Capx
https://dl.dropboxusercontent.com/u/66127489/Crosswalk/AudioTest.capx

Description of Capx

Two Sounds in m4a and ogg.

Steps to Reproduce Bug
    1. Crash on Loading at start.

Observed Result
-

Expected Result
-

Affected Browsers
    [YES] Chrome: (YES/NO)
    [NO] FireFox: (YES/NO)
    [NOTESTED] Internet Explorer: (YES/NO)

Operating System and Service Pack
Window 7 Ultimate 64bit

Construct 2 Version ID
Stable Release (r184)

Firefox and Chrome Android browsers crashing when loading mp3's #274
https://github.com/aduros/flambe/issues/274

-- Google Group post error --
https://productforums.google.com/d/msg/chrome/RJ18WZvitss/edQLMnwNEQEJ
B
59
S
17
G
10
Posts: 158
Reputation: 22,393

Post » Fri Oct 17, 2014 12:06 am

Thanks for pointing this out. Same problem with Asus K00F :(
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Fri Oct 17, 2014 6:33 am

j0schi wrote:Thanks for pointing this out. Same problem with Asus K00F :(


Thanks @j0schi

I hope to find a solution of this, all webapp games or crosswalk games are crash in many tables.
There are a problem with chrome mobile with ogg files, Crash or not play sounds.

i have report an issue to google for this.
B
59
S
17
G
10
Posts: 158
Reputation: 22,393

Post » Fri Oct 17, 2014 11:33 am

jep, i have read it.... but also there seem to be several issues with the sound in crosswalk... basically the whole sound thing lags on start of a layout + you cant controll music volume... it always plays at max vulume at crosswalk. and when you import music as sound it works, but the app takes 5 minutes to start O_o doesnt make sence....

hopefully things get sorted out soon. its very frustrating when you have your whole app ready and cant publish it because BASIC features dont work.

regards
B
19
S
7
G
1
Posts: 222
Reputation: 2,551

Post » Fri Oct 17, 2014 11:51 am

j0schi wrote:jep, i have read it.... but also there seem to be several issues with the sound in crosswalk... basically the whole sound thing lags on start of a layout + you cant controll music volume... it always plays at max vulume at crosswalk. and when you import music as sound it works, but the app takes 5 minutes to start O_o doesnt make sence....

hopefully things get sorted out soon. its very frustrating when you have your whole app ready and cant publish it because BASIC features dont work.

regards


You're absolutely right. :)
B
59
S
17
G
10
Posts: 158
Reputation: 22,393

Post » Mon Oct 20, 2014 5:54 pm

Can't reproduce: your demo runs fine here on a Nexus 5 running Android 4.4.4 in both Chrome for Android (via preview over Wifi) and a Crosswalk build.

Since your bug report suggests having any audio present at all causes the crash, then I am sure we would have heard far more about this, because basically every game that exists would crash all the time in both Chrome and Crosswalk. As far as we are aware, most people's games are working just fine in both.

Perhaps this is an Android bug or an issue with certain device manufacturers, but I don't think it's a Construct 2 bug, so closing.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,145

Post » Tue Oct 21, 2014 6:23 am

Ashley wrote:Can't reproduce: your demo runs fine here on a Nexus 5 running Android 4.4.4 in both Chrome for Android (via preview over Wifi) and a Crosswalk build.

Since your bug report suggests having any audio present at all causes the crash, then I am sure we would have heard far more about this, because basically every game that exists would crash all the time in both Chrome and Crosswalk. As far as we are aware, most people's games are working just fine in both.

Perhaps this is an Android bug or an issue with certain device manufacturers, but I don't think it's a Construct 2 bug, so closing.


Ok thanks @Ashley :)
B
59
S
17
G
10
Posts: 158
Reputation: 22,393

Post » Thu Nov 06, 2014 5:09 pm

I had the same problem with Android 4.2.2, when using the first Android build option. I then changed and used the old build method, the one in the second row, and I was able to run the game with sound.
B
8
S
2
Posts: 47
Reputation: 610

Post » Thu Nov 06, 2014 5:30 pm

Gregster wrote:I had the same problem with Android 4.2.2, when using the first Android build option. I then changed and used the old build method, the one in the second row, and I was able to run the game with sound.


Hi @Gregster
Ashley says

Perhaps this is an Android bug or an issue with certain device manufacturers, but I don't think it's a Construct 2 bug, so closing.
B
59
S
17
G
10
Posts: 158
Reputation: 22,393


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests