Chrome has become extremely laggy - Did the update break?

Discussion and feedback on Construct 2

Post » Sat Jul 19, 2014 3:01 pm

oh sorry i misunderstood you!
B
38
S
11
G
5
Posts: 485
Reputation: 5,340

Post » Sat Jul 19, 2014 3:11 pm

No worries! :)
A big fan of JavaScript.
B
74
S
20
G
69
Posts: 2,208
Reputation: 43,838

Post » Sun Jul 20, 2014 5:08 am

Colludium wrote:My game has a smattering of physics objects rather than just a few basic sprites, and I agree that space blaster is a bit basic for systems testing. Interestingly in the debugger, when I change from Inspect to the Profile screen in Chrome, the fps marches up (from 30 to 50) and CPU use goes right down (50% to 15%). The layout doesn't have that many objects on it (170) and my laptop is super-powerful with an embarrassingly high spec. Meanwhile, in both Firefox and IE11, the same game plays in the debugger at a solid 60 fps with 12% cpu.


The Debugger mode in Chrome has always been much more intensive, my game in debugger mode stutters, but in profile mode watching all the important metrics, its smooth 60 fps and 10-20% CPU used on my i5-3570K.

Im still using Chrome 34 or so, haven't bothered to update.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Mon Jul 28, 2014 10:36 pm

This problem still occurs, and occurs just as badly in a layout with basically nothing going on.

The C2 profiler didn't show anything up. Here's Chrome's CPU profile. I don't know how to interpret this - Could @Ashley or someone else take a look at it?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Tue Jul 29, 2014 1:05 am

Same problem here, im with the latest version of chrome and while testing my game it dropped like 6~8 FPS from previous chrome version... If I preview my game with Node-webkit it runs at solid 60fps
B
32
S
6
G
5
Posts: 437
Reputation: 6,119

Post » Tue Jul 29, 2014 2:27 pm

I actually posted in the forum some time back with the same issue and noticed the same drop in fps&cpu in debugger mode and the back to normalcy of 60fps in profile mode.

viewtopic.php?t=107080 <<link to forum post

I have a feeling it's the combination of an updated chrome and C2. I think you should not judge the performance of your game based on the debugger view. I always switch to profile view after doing changes in debugger view.
But still the issue is annoying , especially since it wasn't ever an issue before.
B
16
S
4
Posts: 138
Reputation: 1,454

Post » Tue Jul 29, 2014 3:30 pm

@pandy this has nothing to do with the debugger at all. The debugger has been a huge drain on performance since it was introduced, nothing's changed in that regard.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Tue Jul 29, 2014 4:28 pm

@sqiddster

Sorry i used the wrong words. I meant in 'inspect' view. The drop in fps is only in the 'inspect' view, whereas the fps&cpu goes back to normal in the other views, i.e 'watch' and 'profile' view

Now i'm aware of the drain, but it has gotten worse. I remember when i worked on my first project, and i used to get low fps, so i had to learn a lot and modify events and finally was able to get a stable 58-60 fps on my project in the 'inspect' view.
fast forward a couple of months, i also started encountering lag as op when i previewed another project i was working on.So i previewed my first project which i had gotten 58-60 fps before, and i find that it's not giving 35-40 fps in 'inspect' view. But like others in this post, goes back to the normal 60fps in the other views(As opposed to before where i got 60fps in all views).

I'm not techy so i'm not ready to point fingers, but i'm certain that something has changed somewhere to negatively affect C2.
B
16
S
4
Posts: 138
Reputation: 1,454

Post » Wed Jul 30, 2014 4:20 pm

Because of this thread I went and looked at my Chrome version...when I did that Chrome auto downloaded the newest version and my FPS immediately dropped from a constant 60 FPS which it has been for months down to around 47-55 and never hits 60 any more... now I have switched to IE for my previews.
B
21
S
5
Posts: 196
Reputation: 1,974

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 29 guests