Chrome Store: Invalid version format in manif

Bugs will be moved here once resolved.

Post » Thu Aug 23, 2012 5:53 am

This was an issue in r99, hoping it would be fixed in 100. I export to Chrome Web Store. When I go to upload my game, I get:

An error occurred: Invalid version format in manifest.

Any idea when this might get fixed? Or is it already and I am doing something wrong?

Here is a copy of the manifest that was generated.

{
     "name": "Kaplow",
     "description": "Catch the bombs before they go KAPLOW!",
     "version": "1.02",
     "manifest_version": 2,
     "app": {
          "launch": {
               "local_path": "index.html"
          }
     },
     "icons": {
          "16": "icon_16.png",
          "128": "icon_128.png"
     },
     "permissions": [
          "unlimitedStorage"
     ],
     "offline_enabled": true
}
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Thu Aug 23, 2012 6:55 pm

Chrome Web Store version numbers have some limitations:

http://developer.chrome.com/extensions/manifest.html#version

The version string can't contain "02", since numbers starting with a 0 are not allowed (for some reason!!). Try 1.0.2 instead!
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Thu Aug 23, 2012 6:56 pm

Ashley, this is the manifest generated by Construct. So construct is generating it wrong?

Ed
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993

Post » Thu Aug 23, 2012 7:57 pm

Construct uses whatever you've set in the 'Version' field in project properties. Presumably you have entered 1.02 there. So you need to change that to fit the Chrome Web Store's requirements.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Fri Aug 24, 2012 1:34 am

OHHHHH!. Thanks for clearing that up.
B
94
S
29
G
11
Posts: 1,545
Reputation: 20,993


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests