Clone Object Undo Crash

All closed bug reports are moved here.

Post » Tue Apr 04, 2017 9:55 am

I'm not sure how to make steps to recreate this crash, but it happens with an initial clone of the sprite, undo to remove cloning, then re-clone the sprite. After that, you undo till you crash.

Observed result
Cannot fully undo a cloned object. It still remains in the Project folder.

Here is how the crash happened. So, if I try to make an undo for a new object after the undo it gets the error "object class name already in use". Confused? Yes.

Expected result
Possible to undo totally after a clone to the session before the clone happened.

Error report information
Type: unhandled exception
File: https://editor.construct.net/r15/main.js, line 61, col 78167
Message: Uncaught Error: object class name already in use
Stack: Error: object class name already in use at be.ǃs$ (https://editor.construct.net/r15/main.js:61:78173) at ne.ǃrYn (https://editor.construct.net/r15/main.js:61:149614) at ne.ǃrYn (https://editor.construct.net/r15/main.js:61:158400) at ne.ǃrYx (https://editor.construct.net/r15/main.js:61:68734) at ne.ǃrYx (https://editor.construct.net/r15/main.js:61:147015) at ne.ǃrYx (https://editor.construct.net/r15/main.js:61:149555) at ne.ǃrYx (https://editor.construct.net/r15/main.js:61:158259) at ne.ǃJZI (https://editor.construct.net/r15/main.js:61:68551) at ne.ǃJZI (https://editor.construct.net/r15/main.js:61:149463) at ǃyF.ǃaG.ǃZrZ (https://editor.construct.net/r15/main.js:63:29354)
Construct 3 version: r15
URL: https://editor.construct.net/
Date: Tue Apr 04 2017 17:40:54 GMT+0800 (Malay Peninsula Standard Time)
Uptime: 8414 s

Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 64-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1.25
Logical CPU cores: 8
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions: EXT_color_buffer_float, EXT_disjoint_timer_query_webgl2, EXT_texture_filter_anisotropic, OES_texture_float_linear, WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_lose_context
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Tue Apr 04, 2017 12:21 pm

@Jaydon

I fixed the bug were the cloned object type was not being removed from the project bar.

I wasn't able to reproduce the other crash though, but from the sound of it, it seems like the crash was tightly coupled with the cloned object type not being removed on undo.

Anyway, the fix will be available in r16, let me know if everything is working properly then.
Scirra Employee
B
10
S
5
G
2
Posts: 147
Reputation: 2,356

Post » Tue Apr 04, 2017 12:38 pm

@DiegoM

DiegoM wrote:I wasn't able to reproduce the other crash though, but from the sound of it, it seems like the crash was tightly coupled with the cloned object type not being removed on undo.


You could safely disregard this crash as it happens because of the left over object not being removed on undo like you mentioned.
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Tue Apr 04, 2017 1:06 pm

@DiegoM

I just found that it also happens to COPY & PASTED objects. Once you did a paste, you cannot undo it away too. Only if you are pasting an object that wasn't in the project.
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Thu Apr 06, 2017 5:51 pm

This is fixed, request close.
B
40
S
9
G
5
Posts: 177
Reputation: 6,805


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests