cloning error

Bugs will be moved here once resolved.

Post » Thu Apr 26, 2012 3:45 am

When I'm editing an event sheet, I can't clone an array. The error is: "Cannot find a layout to put nonworld instance on while cloning"

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Cannot find a layout to place nonworld instance on when cloning

Condition: layout != NULL
File: Projects\ObjectType.cpp
Line: 530
Function: class std::unique_ptr<class ObjectType,struct std::default_delete<class ObjectType> > __thiscall ObjectType::Clone(void) const
Build: release 87 (32-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------
B
12
S
3
G
4
Posts: 55
Reputation: 3,186

Post » Sat Apr 28, 2012 9:47 pm

I got same error here, on Win 7, 64-bit
B
19
S
5
G
5
Posts: 48
Reputation: 4,843

Post » Wed May 02, 2012 11:21 am

Should be fixed in next build.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,228


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests