CocoonJS + C2 + AdMob banners = not working?

Discussion and feedback on Construct 2

Post » Wed Apr 09, 2014 11:14 pm

@Russpuppy, I have had very poor ad fill rates for the last 10 days or so, with cjs 1.4.7 - I have no idea what changed or how to improve it. Luckily I'm making pennies so a fraction of not a lot is not much of a change in revenue!
A big fan of JavaScript.
B
74
S
20
G
71
Posts: 2,228
Reputation: 44,888

Post » Wed Apr 09, 2014 11:55 pm

@colludium interesting. That may be what is happening to me as well, 1.4.7 seems to be having more issues lately with consistently showing ads. When I get some time I'll have to hook my phone up to logcat to see what's going on.
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Thu Apr 10, 2014 1:19 am

I also notice last few days the time to display the first ad is taking longer, when i open my app, it take from 2~5minutes to get first ad showing. and sometimes the gap between ads also longer, there will be minutes without ad. (interestingly, this does not affect cocoonjs launcher, their ad is showing all the time and very quick)

I've emailed mopub with the ad error log i'm seeing in xcode, i'll update when i hear back from them.
Doo Doo Diving App Store | Google Play

Donut Pirate App Store | Google Play
B
17
S
2
G
1
Posts: 195
Reputation: 1,578

Post » Thu Apr 10, 2014 5:11 pm

@hollowthreat I've noticed that too--why do the launcher ads work so well when compiled projects don't? I'd be interested to hear what ludei would say about it. I'm going to try testing out some different things--like refreshing the ads more often. I'm also tempted to look at the exported C2 javascript to see what's going on with requests and see if there's anything that can be improved--maybe once they finally update the CocoonJS plugin things will get better...

I'd be interested to know if this is a problem specific to Construct 2 projects or if others using different frameworks or native code are having the same problem.
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Thu Apr 10, 2014 5:28 pm

At http://stackoverflow.com/questions/5514 ... or-android there is a comment that says "mopub doesnt support "use adsense for backfill". So you get 50% fillrate on admob due to this"

So maybe there's an issue with admob specifically when using with mopub?
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Fri Apr 11, 2014 12:26 am

russpuppy wrote:At http://stackoverflow.com/questions/5514 ... or-android there is a comment that says "mopub doesnt support "use adsense for backfill". So you get 50% fillrate on admob due to this"

So maybe there's an issue with admob specifically when using with mopub?

doubt it, cocoonjs launcher are all admob ads right?
still waiting for mopub reply... :roll:
Doo Doo Diving App Store | Google Play

Donut Pirate App Store | Google Play
B
17
S
2
G
1
Posts: 195
Reputation: 1,578

Post » Fri Apr 11, 2014 4:53 pm

so the last few days I seem to be getting much better fill rate for both banners and full screen ads with 1.4.7, not sure what has changed
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Thu Apr 24, 2014 7:09 pm

I have used Cocoonjs with Mopub to show admob ads on iOS project. However I have faced with a problem and do not have an idea about this problem. In Banner Integration for iOS document on mopub, there are some lines below:

"Adding a banner to your application takes only a few, easy steps:

In your view controller's header file:
Import the MPAdView.h header file and declare an MPAdView *adView property.
Declare that your view controller implements the MPAdViewDelegate protocol."

My problem is that I couldnt find a view controller file on CocoonJs Xcode project. So I cannot add any header file. Do you have any ide for this situation?
B
9
S
2
G
3
Posts: 21
Reputation: 2,302

Post » Thu Apr 24, 2014 9:15 pm

Hello friends,

As stated above 2.0 beta does not show any ads and 1.4.7 is unstable. If it appears at the beginning of the game ads flow no problem but if it does not appear at the beginning no ads for that session. I am working on it so if any of you have a progress please share with us. I will be sharing if I found something.

This is so annoying that after all effort I cannot publish my game because of this.

Thank you
B
3
Posts: 4
Reputation: 190

Post » Fri Apr 25, 2014 5:08 am

i'm using 1.4.7, and mopub seems very unstable? sometimes it loads right away, sometimes no ad for over 5minutes. my game use both iad & admob through mopub, and no iad showing in 2 days :/

its difficult to report issue to mopub like this, somedays it works perfectly fine, somedays not, and they take days to reply.

whats everyone's experience?
Doo Doo Diving App Store | Google Play

Donut Pirate App Store | Google Play
B
17
S
2
G
1
Posts: 195
Reputation: 1,578

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: sunisa2532, taker7 and 26 guests