CocoonJS plugin updates

Discussion and feedback on Construct 2

Post » Sun Oct 19, 2014 3:24 am

Can't for the life of me work out how to get Game Center to login using this plugin.

Anyone have any sure fire steps?


I'm also having a bunch of issues using the 9 patch with this plugin.
B
45
S
9
G
2
Posts: 141
Reputation: 4,197

Post » Sun Oct 19, 2014 3:36 am

Never used 9patch, sorry. You might send and email to [email protected] about the 9patch issue with an example capx.

As for game center, it's nothing more than setting the social service to GameCenter in the CJS object properties. Then using the request login event.

How are you trying to test it? You need to be testing on a device in Xcode and that device needs to be set to use sandbox gamecenter account in the gamecenter settings.
B
101
S
32
G
11
Posts: 1,552
Reputation: 21,667

Post » Sun Oct 19, 2014 1:59 pm

ArcadEd wrote:Never used 9patch, sorry. You might send and email to [email protected] about the 9patch issue with an example capx.

As for game center, it's nothing more than setting the social service to GameCenter in the CJS object properties. Then using the request login event.

How are you trying to test it? You need to be testing on a device in Xcode and that device needs to be set to use sandbox gamecenter account in the gamecenter settings.

Oh wow, I feel like a real dumbass now :D
I didn't know that plugins ad options...

You know if you need to put in the leaderboard name or the id?

Yeah regarding 9 patch it's a combination issue - I am using a 9 patch and applying a webgl effect...
Image
B
45
S
9
G
2
Posts: 141
Reputation: 4,197

Post » Sun Oct 19, 2014 2:06 pm

You put in the leaderboard name when you access it in events.
B
101
S
32
G
11
Posts: 1,552
Reputation: 21,667

Post » Sun Oct 19, 2014 5:43 pm

Ah, this thread is the actual problem: viewtopic.php?f=152&t=115058
B
45
S
9
G
2
Posts: 141
Reputation: 4,197

Post » Mon Oct 20, 2014 1:41 pm

ArcadEd wrote:How are you trying to test it? You need to be testing on a device in Xcode and that device needs to be set to use sandbox gamecenter account in the gamecenter settings.

It's weird, I can get it to login when I test via the Ludei app, but after a compile and running in Xcode it just won't login. Any settings in Xcode that I need to update?
B
45
S
9
G
2
Posts: 141
Reputation: 4,197

Post » Mon Oct 20, 2014 3:33 pm

Not sure. Maybe check.

1. Has your device been registered on your apple dev account?
2. Are you logged out of your normal game center account on the device
3. Do you have Sandbox mode enabled on the device under Settings-Game Center
B
101
S
32
G
11
Posts: 1,552
Reputation: 21,667

Post » Tue Oct 21, 2014 2:05 am

ArcadEd wrote:Not sure. Maybe check.

1. Has your device been registered on your apple dev account?
2. Are you logged out of your normal game center account on the device
3. Do you have Sandbox mode enabled on the device under Settings-Game Center


Yeah, that's the weird thing, I've done all that and it works if I dump the zip in the iOS CocoonJS app, but if I try to run through Xcode - no dice :
Guess I'll have to submit without Game Center again :(
B
45
S
9
G
2
Posts: 141
Reputation: 4,197

Post » Tue Oct 21, 2014 2:32 am

That's weird man, I don't know. I never had the issue before.

Have you tried making an IPA and installing it on your device and seeing if it works?
B
101
S
32
G
11
Posts: 1,552
Reputation: 21,667

Post » Tue Oct 21, 2014 6:48 pm

@Ludei, any news?
B
12
S
3
G
1
Posts: 188
Reputation: 1,377

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: AAPPO and 11 guests