Collision Polygon Problem

Get help using Construct 2

Post » Tue Oct 15, 2013 5:50 pm

Since im not sure if its a C2 bug, i post my problem here.
I have a map(4200x1080) with a detailed Collision shape.

And a Unit

That moves with this event:

But what happens, is that it gets stuck IN the map.
i already tried with a less detailed Shape, sometimes it work, sometimes not.
To be more Precise, the Unit drives more and more down into the map.
But when the Collsion shape at where that happens only is a straight line, it moves completely normal.
Heres when it gets stuck:

Here is the Shape where it gets stuck, can anyone identify my problem?

I would post a CapX if there werent too much or unfinished stuff in it.
If you need more information, np, just say what you need.
"It's done when it's done"

Shadows of War
Buy on Steam ;)
B
24
S
10
G
7
Posts: 253
Reputation: 4,921

Post » Tue Oct 15, 2013 6:02 pm

I had a similar problem before when "riding" on a solid object. Guess this happens on ascending slopes.

You can try to give the moving object a security border for physics, that it always holds a margin of 1px to the ground. Another idea is, to use a physics velocity of Y too, like (57,-1).

Tell me if it works for you.
B
15
S
3
G
5
Posts: 396
Reputation: 4,977

Post » Tue Oct 15, 2013 6:11 pm

@xeed Just tried both methods, no affect...
Although it seemed logical with the velocity of Y.SgtConti2013-10-15 18:11:59
"It's done when it's done"

Shadows of War
Buy on Steam ;)
B
24
S
10
G
7
Posts: 253
Reputation: 4,921

Post » Tue Oct 15, 2013 6:18 pm

Would you send the capx?
B
15
S
3
G
5
Posts: 396
Reputation: 4,977

Post » Tue Oct 15, 2013 7:03 pm

@xeed I sent you a pm with a CapX.
(Not the one with the exact problem, since 400mb is too much to upload.)
"It's done when it's done"

Shadows of War
Buy on Steam ;)
B
24
S
10
G
7
Posts: 253
Reputation: 4,921


Return to How do I....?

Who is online

Users browsing this forum: tarek2 and 2 guests