Collisions on tile maps working in simulation but not mobile

Discussion and feedback on Construct 2

Post » Sun May 29, 2016 4:11 am

Hi there,

I am trying to make a platformer. Whenever I push run game the character stays on top of the tile map like normal. However, whenever I run my game on mobile specifically safari, the platforms work but the collisions are off by one full platform. I think it's a bug.

Has anybody experienced this?
B
71
S
11
G
6
Posts: 375
Reputation: 8,486

Post » Sun May 29, 2016 5:25 am

what kind of html5 to ,apk coverter do you use man?
B
13
S
5
G
4
Posts: 119
Reputation: 3,353

Post » Sun May 29, 2016 10:20 am

If you can post a capx I'd have a look to see if I can see what's going on.
B
69
S
49
G
58
Posts: 398
Reputation: 36,628

Post » Sun May 29, 2016 3:22 pm

The game is almost finished and I don't want to post a CPAX.

It happens when I run the game online on a mobile device.
B
71
S
11
G
6
Posts: 375
Reputation: 8,486

Post » Sun May 29, 2016 3:38 pm

@mammoth - Can you make a sample .capx ? Because it is working fine with my simple platformer test. I used tilemap as a ground with the solid behavior and a player with the platformer behavior and the collision works fine. I did not test on safari though, I used Chrome Mobile.
The Things you can create is only limited by your imagination. If you don't have the skills then use your motivation as a natural force to exceed all expectations. Chadori RebornXD
B
64
S
18
G
90
Posts: 1,119
Reputation: 59,567


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests