Collission detection seems to fail at y-2400.

Bugs will be moved here once resolved.

Post » Tue Jan 13, 2015 8:49 am

Problem Description
In this game, I need a layout of 5000x5000. The layout is filled with sprites, called 'Rock', with a size of 50x50 and distributed across the whole layout.
The sprite pop can walk arround and destroy the 'Rock's after an offset detection.
Now all goes well for most Rocks, but the Rocks on layout Y position = 2400, the collissiondetection failes.
After that specific row of rocks it will continue. So it looks like somewhere between 2400 en 2500 the detection goes wrong. The example included is a rebuild of my game, as per instructions to focus on the problem en reproduce it as pure as possible. I hope I did it ok.

Attach a Capx
____ Upload a Capx to this post ____

Description of Capx
In addition to above, there is 1 layout and 1 event sheet. The idea is that the sprite Pop, can walk around the rocks and destroys them when it hits it.

Steps to Reproduce Bug
  • Run the game/layout
  • Go does with the down key with the sprite Pop. The rocks will destroyed when hit.
  • When you reach y> 2350, you will see some white blocks, which are actually empty spaces. At the level of y= 2399 the Rocks below will not be destroyed. But you can move to an empty space (white rock) to fall one level of rocks below, and you'll see that it continues to work. That why I believe its specifically that coordination, since before and after this area, it works well.

Observed Result
____ What happens? ____
The sprite failes to move further as collision detection seems to fail.

Expected Result
____ What do you expect to happen? ____
I hope, I've did something wrong, then reporting a bug in this super tool :)
Hopefully, you can tell me what I did wrong or should consider or maybe when indeed an error fix it for me? :D

Affected Browsers
[list]
[*] Chrome: YES
[*] Internet Explorer: YES

Operating System and Service Pack
____ Your operating system and service pack ____
Windows 8.1

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____
190 (64bit)
You do not have the required permissions to view the files attached to this post.
B
4
Posts: 4
Reputation: 208

Post » Tue Jan 13, 2015 12:43 pm

Just previewed your capx in chrome and I get the same error.
It does seem like a bug.
B
10
S
2
G
1
Posts: 42
Reputation: 798

Post » Tue Jan 13, 2015 1:35 pm

Closing as works for me in r193. We fixed an issue with 'Is overlapping at offset' in the recent betas so I guess this is probably the same issue. As per the bug report guidelines please only test with the latest release.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Thu Jan 22, 2015 11:37 am

Thanks Ashley!
B
4
Posts: 4
Reputation: 208


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests