Color Blue appears Purple?

Discussion and feedback on Construct 2

Post » Wed Jul 13, 2016 8:03 pm

So I was working with Construct a few days ago that I noticed the color blue appears purple when I run the game I was working on.
Here is a image:
Left in NW.js and Right in the Editor
Image

This shouldn't be a problem from Construct because I don't have this problem with my other computer. So now I'm really confused and don't know what to do to fix this.
B
45
S
19
G
3
Posts: 102
Reputation: 4,598

Post » Thu Jul 14, 2016 2:02 am

Is the blue square an imported image, or did you use the fill tool from within the image editor?
If it's an imported image, what colorspace did you use?
Does it look the different in every browser?

-------

I just did a quick test, and I cannot duplicate the exact colour difference that you have. There will always be a slight variation in colour when rendering in a browser, but that seems way off. I even took a screenshot of your 2 blues and used those in my tests, and the results weren't that noticeable.
Perhaps you could try a slightly different blue, and see that makes a difference. Even just a few small tweaks to the colour may fix the issue. It could just be one of those freak colours that renders wildly different.

Also, your monitor might be enhancing the issue. On my IPS your colour comparisons look much closer in shade than they do on my TN monitor. So that might be partially to blame as well.
Be sure to check out my Metroidvania game, A Hole in the Earth
B
59
S
24
G
3
Posts: 359
Reputation: 5,683

Post » Thu Jul 14, 2016 12:21 pm

They look ALMOST identical on my screen, until I change my viewing angle to a bit higher than normal (if I half stand up it becomes super obvious). It's weird because there is a pretty hard shift in the R component of the colour (68, to be exact).

In your original image there is zero red (0) and a tiny hint of green (3) with blue being at (253)... so it's not 100% "blue". Maybe try R(0) G(0) B(255) and see if there is still a change when rendering?

~Sol
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
84
S
34
G
40
Posts: 3,032
Reputation: 30,499

Post » Thu Jul 14, 2016 6:00 pm

@ryanrybot I used the image editor in C2 and it happens in all the browsers.
@SoldjahBoy I've tested with blue being (255) but it still shows purple when I run the game.
let me explain something:
I know this problem is not from C2 and there is something wrong with my GPU Driver probably.
When I view the screenshot I've taken with the Windows Photos, the right square is blue and the left one is purple. However, when I view the screenshot in Photoshop or browsers like Chrome or Firefox, the right square becomes purple too. In Photoshop I don't even have the color blue in color picker. Look at this screenshot:
Image

See, there is no dark blue, it suddenly becomes purple.
I have searched in Google for hours but I couldn't find a solution. Is it my GPU Driver? or maybe the problem is from Windows? I don't know. I shared it here to see if anyone knows what the problem is
B
45
S
19
G
3
Posts: 102
Reputation: 4,598

Post » Thu Jul 14, 2016 6:51 pm

The search terms to use are "color profile" or "color management" or "icc". It's something to have images display consistency across monitors, it's managed by windows with it's program "color management".

Anyway searching the above term with "chrome" give loads of relevant pages. Here's two:

http://www.dpreview.com/forums/thread/3738355
http://www.marcelpatek.com/blog/2011/11 ... le-chrome/

Anyways the color changes due to a color profile, I don't know if one is using it or not though.
B
94
S
33
G
118
Posts: 5,394
Reputation: 75,849

Post » Thu Jul 14, 2016 9:22 pm

@R0J0hound Thank you so much
I changed the color setting for Photoshop to my monitor profile and now it is fixed.
Going to change color management for Windows and see what happens.
B
45
S
19
G
3
Posts: 102
Reputation: 4,598


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests