Color changing Particles

Get help using Construct 2

Post » Tue Dec 27, 2011 8:44 am

Hey i've been trying to build a color changing particle system but something is wrong and i can't fix it

I've been trying to make some flames but the particle system breaks after a second or sooner and doesn't fade correctly anymore.

It also seems VERY slow and doesn't spawn enough particle for my taste :(

Here's my test .capx:

http://dl.dropbox.com/u/45711709/ParticleEmitter.capx
B
33
S
6
G
7
Posts: 338
Reputation: 7,424

Post » Tue Dec 27, 2011 9:13 am

Get rid of all "For each" conditions, they are totaly useless there.
Gather the two "Every tick" events into a single one.

This should give a first start.

You might also want to change the opacity factor in event 2 (now blank, turn it into a Particle.Opacity > 3) from 3 to 1. (Set opacity Particle.Opacity-1)

Also, I don't know what you tempted to achieve with the yellow particle, but there's a flaw in the logic somewhere as it is now.

Anyway hope it helps already, I get naturaly up to 192 particles with this setup, and all is fluid.

Fixed capxKyatric2011-12-27 09:14:22
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Tue Dec 27, 2011 9:53 am

Well you've cleaned it up a bit but totally broke what i wanted to achieve.

What i've TRIED todo was:

1. Red Particle fades to 50% Opacity
2. Red Particle spawns new invisible yellow Particle
3. Yellow Particle is in same place as red particle
4. Yellow Opacity is increased to near 100%
5. Killswitch for yellow Particle is set to fade it out and then destroy it
B
33
S
6
G
7
Posts: 338
Reputation: 7,424

Post » Tue Dec 27, 2011 10:53 am

That's not what was programmed at first in your first capx.
Anyway Fixed 2.

I added the bullet behavior to particle2 too.
At first I tried to set the positions of particle2 to particle but the problem is the lifespawn of particle is far shorter than the one of particle2, and so the particle2 seemed to "freeze" at some point on the screen, and didn't go further (since there wasn't the instance of particle to pick).

Anyway, tweaking with the values in the capx should help you to get the desired effect.
To me, atm, it looks like some flame/fire.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Tue Dec 27, 2011 1:50 pm

Yay that helped! :D

I've tweeked it a bit and now it's looking kinda how i wanted... a nice comic-style flame / torch effect:

http://dl.dropbox.com/u/45711709/ParticleEmitterFinal.capx
B
33
S
6
G
7
Posts: 338
Reputation: 7,424

Post » Tue Dec 27, 2011 2:22 pm

If I were you, I'd even change Particle2 size.
Try to put it 6X6
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Tue Dec 27, 2011 2:51 pm

Nice!! I was actually going to have to make the same effect but using smoke!! So now i don't have to figure out much just change the color :)
So thanks :)
B
29
S
12
G
7
Posts: 740
Reputation: 7,849


Return to How do I....?

Who is online

Users browsing this forum: BACLog and 20 guests