Constant game hickup.

Bugs will be moved here once resolved.

Post » Mon Jun 03, 2013 9:17 pm

Link to .capx file (required!):
https://dl.dropboxusercontent.com/s/nqlk3hzwte2wurd/BugBall.capx?token_hash=AAFx_0Afcf8P0GyVWFwbp7vybT6is0hHHCYBpZewdKalSA&dl=1

Steps to reproduce:
1. Create Bullet.
2. Observe bullet move across screen.
3. Bullet object hicks up at some point.

Observed result:
Game hicks up.

Expected result:
Smooth continuation.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes
Android : yes

Operating system & service pack: Windows 7, 6.1
System specs : AMD Phenom II X4 955 3.2 GHz
               GeForce 560Ti
               Crucial m4 SSD

Android specs: Nvidia Tegra 3, Quad-Core 1.5 GHz Cortex-A9, wrapped with CocoonJS.


Construct 2 version: r132 Stable, r131 Beta.Xionor2013-06-03 21:50:15
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Mon Jun 03, 2013 9:20 pm

Am I the only one having this issue?

It doesn't happen every single time, more like 50/50.

It also happens when an object is destroyed or created.

Actually it happens all the time. Small hickups, constantly. What is wrong?

EDIT : There is no FPS drops no nothing, it just hacks and hicks up. It's infuriating me.Xionor2013-06-03 21:42:20
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Mon Jun 03, 2013 10:13 pm

Looks pretty smooth to me. Are you sure you're not just spotting V-sync misses?
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361

Post » Mon Jun 03, 2013 10:17 pm

Thank you for the quick reply Ashley!

It appears to vary from machine to machine. I tried it again on an intel i7-2670QM and it runs smooth as butter.
All test machines have Nvidia graphics.

I'll try it on more hardware tomorrow.

What are your test specs Ashley?

It might also be the Vsync. I tried disabling it on my PC, didn't notice a difference, still hacking.

How would I go on about fixing this issue for the Android if it's Vsync? Any ideas on what else it might be?

Could you guys please try this on some extra machines? This is hindering all my ability to make any professional projects with Construct 2 and there has to be other people that experience the same issue, just never reported it.Xionor2013-06-04 07:51:03
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Tue Jun 04, 2013 12:42 am

Tested on AMD E-450 1.6 GHz CPU with on-board radeon graphics.
The graphic jitter/freezes last longer and are a lot more noticable on the slower CPU.Xionor2013-06-04 06:06:29
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Tue Jun 04, 2013 6:17 am

Possible problem found!

The jitter/hiccup dissapears almost entirely(appears only 2-3% of the times) with Fullscreen in Browser OFF and WebGL in Browser OFF. Any other setting creates hiccups in random manners.

However using a more normal game demo(almost anything) the problem persists, even with said setting.

I also tested with Scirra's own Space Blaster game - strangely enough to my eyes it appears to be running perfectly fine.


Further testing:

With Fullscreen on anything other than OFF.

With WebGL on : It jitters/sutters/hiccsup almost every time it reaches about 80% of the window width. Reproducable almost every time.

With WebGL off : Jitters at 80% of window width only like 30% of the times. Instead it it jitters at random places at random times. 2 hardly ever the same.

Clear Background on/off seems to make little reproducable result, other than i get different results every time i set it on/off and back again.Xionor2013-06-04 06:45:55
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Tue Jun 04, 2013 6:48 am

I just did a bunch of testing to determine the source of a stuttering problem as well, the solution for me was to turn on windows aero, as with it off, Windows's window manager was not hardware accelerated. However, that was a solution for vista, and I don't think it applies to windows 7, but you might want to give it a try if it's not on already.

Another solution I had quite a while ago was to update my graphics card drivers, which is always worth trying.
Moderator
B
95
S
34
G
33
Posts: 3,007
Reputation: 27,876

Post » Tue Jun 04, 2013 7:01 am

Disabled Aero. Made little difference. Only thing that fixes it on the Cubes capx is WebGL 0 fullscren 0. Does not work on other games i try, apart from Space Blaster which appears almost always stutter free somehow(could be my eyes).

The problem also appears on Android 4.0.3, both wrapped via CocoonJS and on browser(Chrome Beta and latest Stable release), with or without WebGL. This leads me to believe it's something either in HTML5 or Construct 2 that makes things go out of sync every now and then.

The i7-2670QM laptop where it ran perfectly had Aero with all the gizmos enabled.

I have the newest drivers on all machines. Even reinstalled them to confirm it's not them.
A newer Android version could help it, but the fact that almost 60% of android users use 4.0 and below doesn't help me with that.


EDIT : Tried many things - Older Construct versions, different ways of making the motion(both dt time and without), on diffferent platforms/devices, same result - Jitter.

As last time, WebGL on makes the jitters consistent and repeatable. WebGL off makes them random. Both WebGL and Fulscreen off makes the issue non-existant on the Cube demo, but on other more complex movements theres no effect.
Xionor2013-06-04 07:49:07
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Tue Jun 04, 2013 12:39 pm

Why was the topic closed?
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Tue Jun 04, 2013 12:42 pm

Closing, I don't think this is a C2 bug. Our old native engine sometimes dropped frames in windowed mode, because to v-sync 100% accurately means synchronising every 16ms to <1ms accuracy, and often OS tasks or other software steal just a little bit too much CPU time and it misses the sync. The visual appearance is one frame being displayed twice as long as it ought to (32ms instead of 16ms) every couple of seconds, which if you are watching with hawk eyes is just about noticeable as a "hiccup" or "jank". In real games like Space Blaster though, usually it's virtually impossible to notice, since the motion is slower and the contrast is lower. There's not much to be done other than boost the process priority. Going in to fullscreen (F11) might actually help, since the browser might boost its own priority when fullscreen, as well as closing all other running apps.
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest