Construct 0.96 released

New releases and general discussions.

Post » Thu Jul 03, 2008 1:10 pm

http://downloads.sourceforge.net/constr ... irror=osdn

Construct 0.96 has now been released, featuring slow-motion effects, new audio features in Directsound, stability improvements, lowered system requirements, and the usual boatload of bug fixes.

It's been a while since the last build, but it's summer in my local hemisphere, which calls for occasionally going outdoors! Changelog as usual is below.

Don't forget you can support Construct's development by donating via the button on the main page.

Behaviors
- [ADD] Platform behavior: Compare Gravity
- [FIX] Platform behavior: Hanging in some situations

Event sheet editor
- [FIX] Use expression now works
- [FIX] 'Else' events now work. They can also be chained to create if-else if-else style events. Else events do not currently work after triggers.
- [CHANGE] The 'Always' system expression has been renamed to 'Always (every tick)'. This is to better explain that it actually runs frequently as opposed to continuously.
- [CHANGE] 'Start of application' removed: use 'Start of layout' on first layout instead.

General
- [FIX] Deleting objects in cloned layouts now doesn't crash
- [FIX] Removing event sheets now closes all relevant windows before deleting (fixes crash)
- [FIX] Saving and loading of Layer Zoom X/Y rate
- [FIX] Items now don't repeat in the recent files area
- [CHANGE] Removed 'Exchange' button on Insert object dialog until it is completed
- [CHANGE] The way plugins are configured has been changed to be more reliable. This should fix people who cannot use the IDE due to plugin errors on startup.

Layout editor
- [FIX] Paste clone now pastes in correct position
- [FIX] Layout editor rendered effects incorrectly when zoomed

Picture editor
- [FIX] VRAM usage now reduced when using the picture editor. Construct may now work on 64/32MB cards - please test and let me know.
- [FIX] Errors while opening the picture editor should be properly reported and not crash.

Plugins
- [ADD] Directsound: Effects system. Allows for multiple effects to be queued up on to one or all sounds; supports Chorus, Compression, Distortion, Echo (Delay), Environmental Reverberation (via presets), Flanger, Parametric Equalizer and Gargle.
- [ADD] Directsound: Time scaling option: when enabled, all playing samples adjust frequency according to the runtime's time scaling.
- [ADD] Directsound: Epilogue time option: optionally add silence to the end of all samples, to prevent effects like Reverb being cut short when the sound ends.
- [ADD] Particles: 'One shot' mode, to act like an explosion. Destroys itself when all particles have disappeared.
- [ADD] 3D Box: 'Z buffer' property, which can be turned off to allow for certain 3D effects
- [ADD] File: FileListFiltered expression, to retrieve filtered list of files in a directory, eg. File.FileListFiltered("C:\", "*.mp3")
- [FIX] Common dialog issues with getting selected file
- [FIX] Sprite: 'On animation finished' and 'Is animation playing' (using named animations) now work correctly
- [FIX] Edit box: Handling of new line characters
- [FIX] Function object: Isolated condition aliasing bugs (still known bug in inline calls)
- [FIX] Mouse & Keyboard: Can detect mouse over text objects
- [FIX] Box object: now draws pixel-perfectly same size at runtime as in the layout editor
- [CHANGE] DirectSound 'Set Frequency': Now uses a frequency multiplier instead of absolute frequency
- [CHANGE] DirectSound caching engine rewritten to perform better and work in a way compatible with the effects engine

Runtime
- [ADD] Time scaling: allows for slow-motion and fast-motion effects, integrates with Directsound to adjust audio frequency when 'Auto time scaling' enabled in Directsound
- [ADD] 'DisplayDevice' expression; returns display device name, eg. "NVIDIA GeForce 8800 GT"
- [FIX] Effects using pixelWidth and pixelHeight now have correct values for zoomed layers; affects blurs and warps etc.
- [FIX] 'End of Application' now triggers.
- [FIX] Runtime crash when incomplete containers in the layout.
- [FIX] Crash in debugger when changing layouts.
- [FIX] Dragging titlebar sometimes stuck to mouse.
- [FIX] Syntax error using Mouse & Keyboard object in Python applications.
- [FIX] Crash changing effect parameters with an expression in the same object.
- [FIX] Crash transitioning to the same layout. Transitions to restart the layout are not supported so in this case the layout restars without a transition.
- [FIX] 'Timer equal to...' condition not triggering after a layout restart.
- [CHANGE] F7 no longer shows VRAM usage messagebox at runtime.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,228

Post » Thu Jul 03, 2008 1:17 pm

Nice, i see you didnt fix the Angle on Clones or connection with originals like picture editing(explained in bug tracker) still nice build tho.
B
4
S
2
G
4
Posts: 719
Reputation: 2,938

Post » Thu Jul 03, 2008 1:55 pm

Great work as usual Ashley, I can't wait to give it a try :)! You certainly deserve to soak up some sun :D
B
2
G
4
Posts: 57
Reputation: 1,164

Post » Thu Jul 03, 2008 2:01 pm

I think I still have the problem that If I use Construct for sometime and click something it crashes. Then I load the application, click the same thing again and it works... but then it crashes again when I do something else. :/

But of course I'm happy to download patches about every month ;)
B
5
S
2
G
8
Posts: 53
Reputation: 3,222

Post » Thu Jul 03, 2008 2:58 pm

Awesome!
B
134
S
65
G
16
Posts: 1,765
Reputation: 19,188

Post » Thu Jul 03, 2008 4:07 pm

Great now i can make at last make some progress with my game!

PS test my game PhyXChallenge and tell me how i should improve it and stuff like that!
B
11
S
3
G
4
Posts: 622
Reputation: 3,186

Post » Thu Jul 03, 2008 8:41 pm

Graphics editor works on my laptop, which is a huge boon for me. Animation playing seems to work, but animation finished still seems somewhat bugged, but every time I try and make an example it fails. Maybe something farther back in my code is messing it up. If I can figure it out, i'll post examples.

Great work, either way.

Edit: Got it. Little weirdness maybe, but nothing that can single out. Maybe it was just my own stupidity. Ah well.
B
12
S
4
G
4
Posts: 238
Reputation: 2,426

Post » Thu Jul 03, 2008 9:28 pm

Bug: new game, insert a sprite, import an image and the graphic doesn't show up in the picture editor. :(
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Thu Jul 03, 2008 9:38 pm

[quote="Arima":1mgbq1lp]Bug: new game, insert a sprite, import an image and the graphic doesn't show up in the picture editor. :([/quote:1mgbq1lp]
Ditto, and when I try to draw anything it just vanishes.
B
2
S
2
G
4
Posts: 259
Reputation: 1,968

Post » Thu Jul 03, 2008 10:52 pm

Good update otherwise, but I can't seem to access my .cap's preview anymore or use the picture editor to draw anything :(
B
4
S
2
G
6
Posts: 50
Reputation: 1,690

Next

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 1 guest