Construct 0.97.5 released

New releases and general discussions.

Post » Sat Sep 27, 2008 11:28 pm

[size=200:3iqxidsf]Download 0.97.5 now[/size:3iqxidsf]

A fairly small update - a lot of us have been busy. I spent a while trying to get some multi-monitor support as well, but I just couldn't get it working...

Directsound is deprecated in this build and will be replaced as soon as possible with the XAudio2 plugin, since Directsound is not properly supported on Vista. You will have to recode all your audio events for the new plugin. Inserting Directsound or opening an existing .cap with Directsound will prompt a warning.

Full changelog:

General
- [ADD] 'Is group enabled' system condition
- [FIX] Crash closing projects
- [FIX] 'Get object count' system expression inserted the expression "ObjectCount" which was invalid. The correct expression is "TotalObjects"; this has now been corrected.
- [FIX] '&' can now be used in comments
- [CHANGE] Layer parameters in system ACEs re-titled to "Layer name or number" to clarify that you can refer to layers by their names as well as numbers.

Plugins
- [FIX] 3D Box issue
- [FIX] Crash setting mesh distortion on Sprites
- [CHANGE] Sprite mesh distortion 'set displacement at': opacity is a value 0-100 like the rest of Construct; was previously 0-1, multiply your current value by 100 to correct your opacity values
- [CHANGE] Sprite mesh distortion 'set displacement at': x, y, u and v displacement were using texture coordinates, which was not a useful way to use mesh distortion. These have now changed to take a value in pixels. Old applications using mesh distort need to multiply these values by the object width for X and the object height for Y in order to restore the same functionality as before.

Runtime
- [ADD] Debugger: warning when referencing nonexistant layers or event groups in system ACEs. Should pick up any errors caused by typos.
- [FIX] Crash with incomplete containers in layout editor and one of the missing objects had a behavior
- [FIX] ScrollXLeft, ScrollXRight, ScrollYTop, ScrollYBottom gave wrong values when passed a layer parameter
- [FIX] Debugger: warnings sent on start of layout are now shown correctly
- [FIX] Debugger: window moves to upper left of screen instead of sitting on top of the runtime window
- [FIX] Behaviors + mouse & keyboard object input no longer responds when window has not got focus
- [FIX] Crash using load/quickload when the save was on a different layout
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Sat Sep 27, 2008 11:59 pm

[quote="Ashley":2xq1u37b]
- [FIX] Behaviors + mouse & keyboard object input no longer responds when window has not got focus
[/quote:2xq1u37b]
YES!
B
2
S
2
G
5
Posts: 236
Reputation: 2,122

Post » Sat Sep 27, 2008 11:59 pm

Yes! Yes! Yes! Great work :)
Don't know why, but Directsound wasn't working at my machine at all (WinXP SP3). Maybe XAudio2 will do just fine ^^.
B
6
S
3
G
6
Posts: 219
Reputation: 3,013

Post » Sun Sep 28, 2008 12:12 am

*thumbs up*

Get an error on opening Construct about template.csx not working, but everything runs fine.
B
2
S
2
G
5
Posts: 391
Reputation: 2,432

Post » Sun Sep 28, 2008 12:18 am

gah!!!! its downloading SO SLOW!!! its prob just my computer... it usually downloads in like 15 seconds... oh well. keep up the good work ashley!
B
2
G
4
Posts: 35
Reputation: 1,120

Post » Sun Sep 28, 2008 12:20 am

figured it out... the osdn mirror is just really slow
B
2
G
4
Posts: 35
Reputation: 1,120

Post » Sun Sep 28, 2008 12:28 am

Nice! The "Is group enabled" will be quite handy.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Sun Sep 28, 2008 1:29 am

I get an error loading the 3D box with this build :cry:

this happen to anyone else?!
B
134
S
65
G
16
Posts: 1,765
Reputation: 19,188

Post » Sun Sep 28, 2008 9:31 am

No, 3dBox works fine.
B
6
S
3
G
6
Posts: 219
Reputation: 3,013

Post » Sun Sep 28, 2008 9:41 am

I get two errors at start:

[code:3o3rclg0]Error loading C:\Program Files\Scirra\Construct\Plugins\3DBox.csx (126) - this plugin may not be available![/code:3o3rclg0]

[code:3o3rclg0]Error loading C:\Program Files\Scirra\Construct\Plugins\Template.csx (14001) - this plugin may not be available![/code:3o3rclg0]

With this build.
B
4
S
2
G
6
Posts: 50
Reputation: 1,690

Next

Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 2 guests